Opened 13 years ago

Closed 11 years ago

#976 closed Defect (Duplicate)

Cycling a channel doesn't work and can cause CPU spikes in some circumstances

Reported by: Scaredy Owned by: timothy
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Normal Keywords:
Cc:

Description

The circumstances I was able to make this occur:

  • Have Colloquy setup to auto-join a single channel and do not join any others
  • Start Colloquy fresh
  • Use /cycle #channel (Using /cycle without parameters or /hop don't cause it)
  • Colloquy will rejoin channel, then part it again, which is not the expected behaviour
  • Upon rejoining the channel manually, the CPU may spike. This part doesn't happen 100% of the time.

I'm attaching a sample in case it may aid in troubleshooting.

Change History (2)

comment:1 Changed 13 years ago by Rinoa

  • priority changed from low to normal
  • Severity changed from minor to normal

Related to #728.

comment:2 Changed 11 years ago by timothy

  • Resolution set to duplicate
  • Status changed from new to closed

CPU hogging fixed in [4091] - Same as #1306. The parting, rejoin, and automatically parting again is a duplicate of #728.

Note: See TracTickets for help on using tickets.