Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#904 closed Enhancement (Won't Fix)

Close button (x) hides Colloquy window instead of closing it?

Reported by: mxz Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Normal Keywords: interface, button behaviour
Cc:

Description

Could include option to change the behaviour of the CLOSE (x) button for the Colloquy window. Option A: (x) closes windows, B: (x) hides the window. Currently (x) closes window, parts you from every chatroom but keeps application active in the dock and connection to server which is a bit confusing. Changing this behaviour would allow to quikcly hide the window without quitting chat by accident.

Change History (5)

comment:1 in reply to: ↑ description ; follow-up: Changed 10 years ago by offlinePK

Replying to mxz:

Could include option to change the behaviour of the CLOSE (x) button for the Colloquy window. Option A: (x) closes windows, B: (x) hides the window. Currently (x) closes window, parts you from every chatroom but keeps application active in the dock and connection to server which is a bit confusing. Changing this behaviour would allow to quikcly hide the window without quitting chat by accident.

This is the first thing I have noticed about Colloquy and it is a major annoyance as it is the only mac app to behave this way.

comment:2 Changed 10 years ago by alzeih

I agree, would love this to be fixed. Please!

If for some reason the default behavior needs to be preserved, giving the option of closing the window and staying connected to chats would be great!

comment:3 in reply to: ↑ 1 Changed 9 years ago by jane

  • Resolution set to wontfix
  • Status changed from new to closed

Replying to offlinePK:

This is the first thing I have noticed about Colloquy and it is a major annoyance as it is the only mac app to behave this way.

Closing the window doesn't necessarily mean the application should quit. See the Apple HIG: http://developer.apple.com/documentation/UserExperience/Conceptual/AppleHIGuidelines/XHIGWindows/chapter_18_section_5.html#//apple_ref/doc/uid/20000961-TPXREF56

Replying to mxz:

Option B: (x) hides the window.

I don't think any application hides the window by clicking on close/typing cmd+w (otherwise how do you actually close the window? by quitting the app?...). This also goes against Apple HIG (see above).

Currently (x) closes window, parts you from every chatroom but keeps application active in the dock and connection to server which is a bit confusing. Changing this behaviour would allow to quikcly hide the window without quitting chat by accident.

I can understand this can be confusing, but a channel isn't the same as a connection. You can be connected to a network without being on a channel.

I think what you are looking for is an (irc) bnc, or something like what Linkinus provides along the lines of a bnc.

comment:4 Changed 9 years ago by alzeih

  • priority changed from Normal to Low
  • Severity changed from Normal to Trivial
  • Version changed from Latest Nightly to Built Source

For those looking for a workaround, in JVChatWindowController.h, comment out the two lines shown (shortened for clarity)

  • (BOOL) windowShouldClose:(id) sender {

if( [... count] < 1 ) return YES;
if( NSRunCriticalAlertPanelRelativeToWindow( ... )
return YES;
return NO;

}

This has the effect of "disabling" the close button with 1 or more open channels, otherwise it will close the chat window when clicked. It's not intelligent, but it's enough to stop it bugging you or closing the window on accident.

(note the actual code has count <= 1 , which might be the cause of some annoyance for those who use exclusively one channel, and don't have warning when closing?)

It does cause the connections window to open when the dock icon is clicked after a window is closed however, which might be just as annoying as the fix solves. And probably some other weird behaviour. YMMV basically.

Also, I actually agree with this bug's resolution (wontfix). 5 minutes of hacking has fixed (enough for me) the only annoyance this app has that stops it from being a killer app though (imao).

Hope this is useful to someone.

comment:5 Changed 9 years ago by alzeih

  • priority changed from Low to Normal
  • Severity changed from Trivial to Normal
  • Version changed from Built Source to Latest Nightly

(reverting status changes)

Note: See TracTickets for help on using tickets.