Opened 13 years ago

Closed 10 years ago

#853 closed Defect (Won't Fix)

Colloquy freezes after a few hours usage on 10.3.9

Reported by: terrellrussell+colloquy@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Blocker Keywords: beachball
Cc: grahamperrin

Description

10.3.9 on this machine. never saw this problem before - it has happened every few hours (8-10 times now) after upgrade to 2.1 (3338) after autoupdate prompt.

consultation in #colloquy suggested it might be scrollback setting (was at 1000) and so i lowered it to 500. since then, i've seen three beachballs and i had to force quit each time to get back in.

had 4-5 rooms open each time. usually no more than a couple messages in the scrollback(s) before i see that the app has frozen. not sure if it has ever frozen with *no* messages in scrollback for all the rooms.

i have no crash logs in CrashReporter? as the app is freezing, not actually crashing.

Change History (16)

comment:1 Changed 13 years ago by terrell

confirmed - just froze with nothing in scrollback for all connected rooms.

clearing out preferences now - will keep a copy of the plist for later if helpful.

comment:2 Changed 13 years ago by terrell

did not help - same freezing, even with new plist.

this is a blocker - app is not usable in this state.

comment:4 Changed 13 years ago by terrell

comment:5 Changed 13 years ago by terrell

lots of crashes on connect (documented and fixed since these builds)

retrashed the plist and connecting with 3321.

comment:6 Changed 13 years ago by terrell

same freezing - with clean plist and 3321.

i'm stumped.

comment:7 Changed 13 years ago by timothy

  • Status changed from new to assigned
  • Summary changed from colloquy freeze (beachballed) after a few hours usage - did not happen prior to 3338 to Colloquy freezes after a few hours usage on 10.3.9

Can you do a sample next time this freeze happens? You can do a sample on a frozen app in the Activity Monitor or from the terminal.

In the terminal:
sample Colloquy 10

In Activity Monitor: Select Colloquy in the list then pick Sample Process in the View menu.

Then attach the file here.

comment:8 Changed 13 years ago by Koen Vervloesem <kvervloesem@…>

I have the same problem, except that Colloquy is crashing, not freezing. It has happened more than 10 times today. This is Colloquy 2.1 (3338) on Mac OS 10.3.9. I have sent a crash report.

comment:9 Changed 12 years ago by timothy

This is hanging every time in objc_sync_enter, which is the @synchronized directive in ObjC. I have no idea why this would be happening. How large are the rooms you join?

comment:10 Changed 12 years ago by centosian

I get a hang that fits the same description on OSX 10.4.8 using colloquy 2.1 (3386). Added as per suggestion by akempgen. Will do 'sample' and 'activity monitor' debugging as mentioned above if/when this occurs again.

comment:11 Changed 12 years ago by centosian2

Just added a crash case with Colloquy 2.1 (3410). It didn't actually lock up with the beach ball this time, but the message pane wouldn't scroll or update.

comment:12 Changed 12 years ago by centosian2

oh - scrollback is 250, os 10.4.8

comment:13 Changed 12 years ago by timothy

This seems like a bug with @synchronize in 10.3.9. Not likely fixable on our end. Soon 10.3.9 will not be supported anymore when Leopard ships...

comment:14 Changed 12 years ago by Rinoa

Also see #1009

comment:15 Changed 10 years ago by grahamperrin

  • Cc grahamperrin added

comment:16 Changed 10 years ago by jane

  • Resolution set to wontfix
  • Status changed from assigned to closed

If related to events like netsplits or receiving too much data, please reply on #381.

If this happens on an OS newer than 10.3.9, please create a new ticket (or reply on a ticket if you see one related to your issue).

If this happens on 10.3.9, please download Colloquy 2.1 build 3761, as that is the last supported version of Colloquy on Panther, and Panther will no longer be supported.

Note: See TracTickets for help on using tickets.