Opened 13 years ago

Closed 13 years ago

#826 closed Defect (Fixed)

App update fails under non-admin account

Reported by: Macskeeball Owned by: timothy
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Normal Keywords: sparkle update admin permissions
Cc:

Description

For security reasons, I keep my everyday user separate from my Mac's admin account. Colloquy is stored in /Applications which is of course standard user accounts do not have privileges to modify unless admin credentials are provided (ex: the Finder). Colloquy's autoupdate functionality, however, fails to put up a prompt asking for admin credentials. Adium (as of the 1.0 betas) also uses Sparkle, and it asks for the admin user and password if needed. I don't know if that's Adium specific or if they're using a newer version of Sparkle.

Change History (1)

comment:1 Changed 13 years ago by timothy

  • Resolution set to fixed
  • Status changed from new to closed

I have updated to Sparkle 1.1, so this is the same or newer version as Adium.

Note: See TracTickets for help on using tickets.