Opened 12 years ago

Closed 10 years ago

#814 closed Defect (Fixed)

Nick complete and nicks 2x visible if Ops have -@ and *@ in front.

Reported by: Thorne^ Owned by: timothy
Component: Chat Core (IRC) Version: 2.1 (Mac)
Severity: Major Keywords:
Cc:

Description (last modified by timothy)

There are 3 problems with build 3338 and many builds before:
On irc networks with special op chars ( -@nick , and *@nick) are 2 errors:

No.1 Nick completor doesnt work if the nicks have this chars in front of the @.
No. 2 If people with -@ quit on this kind of networks, the nick stays still in the nicklist, the chatter returns and his nick is 2x in the nicklist

A solution to solve problem 1 and 2 could be to add other colors (green and orange for example) for Channel OPs and Owners with the -@ and *@ for the icon in front of the nicks.

Change History (10)

comment:1 Changed 12 years ago by rinoa

  • Resolution set to duplicate
  • Status changed from new to closed

You've already reported this once. Duplicate of #642

comment:2 Changed 12 years ago by timothy

Best fix i can do in [3340].

comment:3 Changed 12 years ago by timothy

  • Resolution duplicate deleted
  • Status changed from closed to reopened

This is not fixed, I had to roll out this change in [3341]. Non-standard IRC servers are very hard to support. What server supports these ludicrous prefixes?

comment:4 Changed 12 years ago by akempgen

  • Summary changed from Nick complete and nicks 2x visible if Ops have -@ and *@ in front. Whois bug on dcc send with ircops to Nick complete and nicks 2x visible if Ops have -@ and *@ in front.

see #815 for the whois bug, dont report more than one issue per ticket please

comment:5 Changed 12 years ago by akempgen

and the network that has these prefixes is irc.holics.net

comment:6 Changed 11 years ago by timothy

  • Component changed from Colloquy (GUI) to Chat Core (IRC)
  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from reopened to closed

The irc.holics.net server users DreamIRCd-3.1.4-Phoenix, which does have double prefixes. These double prefixes are a complete deviation from the IRC spec. There is no way for Colloquy to support these non-standard IRC servers while correctly supporting standard IRC servers.

comment:7 Changed 11 years ago by timothy

Landed a new fix in [3768].

comment:8 Changed 11 years ago by timothy

And [3769].

comment:9 Changed 10 years ago by Robby

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:10 Changed 10 years ago by Robby

  • milestone set to Colloquy 2.2
  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.