Opened 13 years ago

Closed 11 years ago

#774 closed Defect (Works for Me)

Pasting into text editor after Select All splits up lines

Reported by: jruderman@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Major Keywords:
Cc:

Description

I'm using Colloquy version 3315 (latest nightly).

Steps to reproduce:

  1. /msg (self) foopy
  2. Switch to the private message window.
  3. Click the main content area to focus it.
  4. Press Cmd+A to select all (do NOT select the two lines with the mouse)
  5. Press Cmd+C to copy.
  6. Paste into TextEdit? or Smultron or Firefox (data:text/html,<textarea rows=10 cols=30>).

Result: each line of chat becomes 6 lines of pasted text, with a line for each piece of punctuation as well as a line for the timestamp, a line for the nick, and a line for the message:

[
11:12pm
]
Jesse_
:
foopy

Expected: each line of chat become 1 line of pasted text (with a timestamp), like when I select with the mouse.

Change History (9)

comment:1 Changed 13 years ago by nharkins@…

+1: this is the one potential "showstopper" for an otherwise awesome irc client. many operations departments use internal irc for communication, and need to copy/paste lines into shift reports. having to edit/reconcatenate those lines back together is just over the threshold of finding another tool. please fix, and much thanks in advance.

comment:2 Changed 12 years ago by nharkins@…

ok, this is weird. a coworker also had this problem, as i still do, and it somehow "fixed itself" without him knowing what he changed. we've gone over every configuration option on the same version of the software and all appears to be indentical, but i still have the buggy behavior...

comment:3 Changed 12 years ago by akempgen

a workaround when pasting to textedit is to switch the document to plain text first (format menu > convert to plain text, or cmd-shift-t) and then paste...

comment:4 Changed 12 years ago by akempgen

in textedit "Edit menu > Paste and Match Style" (option-shift-command-V) is also an alternative and so is pasting to the colloquy input box first and copy from there.

smultron seems to "paste and match style" by default now, so no problem there anymore.

comment:5 Changed 12 years ago by codeman38

Paste and Match Style doesn't work when the text was selected using Select All; *nothing* is pasted in that case. It only works when part, but not all, of the transcript has been selected.

comment:6 follow-up: Changed 12 years ago by Christina

This problem doesn't occur for me when using Select All (I can't even Select All, perhaps because I'm using Standard style?). Even if I copy a few lines of text, this will occur. As well, the workaround mentioned in this ticket doesn't work either.

My concerns are the exact same as ticket #1032
A secondary issue (as that ticket also mentions) is that timestamps aren't selected for the first message.

I would love it if both the primary and secondary problems were fixed (they are probably the most trouble I am experiencing with this client at the moment). But, I understand it's pretty hard to fix such a bug that is not easily reproducable. I myself successfully copied and pasted for over a year in Colloquy. Just recently (without making any alterations), my copying and pasting abilities went screwy.

comment:7 in reply to: ↑ 6 Changed 12 years ago by akempgen

Replying to Christina:

Just recently (without making any alterations), my copying and pasting abilities went screwy.

Did you maybe install Safari 3?

comment:8 Changed 11 years ago by RandyWalker

I can confirm this behavior (multiple lines). I cannot get the paste to look good no matter what I do.

comment:9 Changed 11 years ago by akempgen

  • Resolution set to worksforme
  • Status changed from new to closed

this was a bug in the Safari 3 Beta and has apparently been fixed in newer versions of WebKit? (tested with r26183)

Note: See TracTickets for help on using tickets.