Opened 13 years ago

Closed 13 years ago

#769 closed Enhancement (Duplicate)

Automatic UTF8 detection?

Reported by: anonymous Owned by: timothy
Component: Colloquy (Mac) Version: 2.0 (Mac)
Severity: Blocker Keywords:
Cc:

Description

What about implementing UTF8 detection as featured in numerous other IRC clients on other platforms?
As the feature seems to work today, the only way to be able to parse UTF8 correctly seems to be to set the client to spew out UTF8 itself.
A prefered mode would be to allow the client to detect and parse UTF8 regardless of whatever codepage is using used in a channel, say latin-1, while still outputting whatever the prefered codepage of the channel is.
UTF8 detection in itself is a pretty trivial matter to implement.

Change History (1)

comment:1 Changed 13 years ago by akempgen

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #188

Note: See TracTickets for help on using tickets.