Opened 13 years ago

Closed 12 years ago

#764 closed Defect (Fixed)

User modes are not recognized on old bahamut irc servers

Reported by: akempgen Owned by: timothy
Component: Chat Core (IRC) Version: Local Build
Severity: Critical Keywords: user modes nick list enterthegame bahamut server software
Cc:

Description

as someone in the chat room pointed out, on irc.enterthegame.com user modes are not recognized at all, instead they are shown as @nick or +nick in the user list and cause the usual problems.

the server is running an old version of the bahamut server software and i noticed a difference in the PREFIX statement which may be the cause of this:

001: Welcome to the EnterTheGame IRC Network nightstalker
002: Your host is FL.EnterTheGame.Com[@0.0.0.0], running version bahamut-1.4(28)
003: This server was created Sun Mar 19 2006 at 01:15:40 EST
004: FL.EnterTheGame.Com bahamut-1.4(28) oiwscrknfydaAbghe biklmnoprRstvc
005: NOQUIT WATCH=128 SAFELIST MODES=6 MAXCHANNELS=20 MAXBANS=100 NICKLEN=30 TOPICLEN=307 KICKLEN=307 CHANTYPES=&# PREFIX=@+ NETWORK=EnterTheGame SILENCE=10 are available on this server

The server says PREFIX=@+ and not PREFIX=(ov)@+ like other servers do.

Change History (4)

comment:1 Changed 13 years ago by belthesar@…

On irc.enterthegame.com, it seems the userlist issues are only prevelent on join. Users that are voiced or oped while in the channel are interpereted appropriately.

comment:2 Changed 12 years ago by deadwing

I have the same problem with a server running dancer 1.0.32-2.

comment:3 Changed 12 years ago by volt_knuckle

This problem also seems to occur on all servers in the Otherside network.

comment:4 Changed 12 years ago by timothy

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed by [3665].

Note: See TracTickets for help on using tickets.