Opened 13 years ago

Last modified 10 years ago

#728 reopened Defect

rejoining a room you just left (cmd w) causes colloquy to join and instantly part the room again

Reported by: akempgen Owned by: timothy
Component: Chat Core (IRC) Version: 2.1 (Mac)
Severity: Critical Keywords: join part room
Cc: grahamperrin, gurpartap@…

Description

rejoining a room you just left (cmd w) causes colloquy to join and instantly part the room again, so you have to join twice to actually get back into the room. not sure if thats a reason, but i could only reproduce it with auto-join channels...

the join/part thing sounds related to #724

Change History (9)

comment:1 Changed 12 years ago by timothy

  • Status changed from new to assigned

comment:2 Changed 12 years ago by timothy

  • Resolution set to duplicate
  • Status changed from assigned to closed

comment:3 Changed 12 years ago by timothy

Dupe of #419.

comment:4 Changed 12 years ago by Rinoa

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Not related to #419. Dupe of #290. Reopening. Better description.

comment:5 Changed 12 years ago by Rinoa

  • Version changed from Built Source to Latest 2.1

Also see #976

comment:6 Changed 12 years ago by NTiOzymandias

From what I can tell, this bug actually does not cause the channel in question to close instantly. Rather, it closes as soon as there's any activity in another channel (possibly the same channel? I can't tell).

comment:7 Changed 10 years ago by grahamperrin

  • Cc grahamperrin added

comment:8 Changed 10 years ago by grahamperrin

Note to self (before I forget) (should be a separate ticket but may be related to this ticket:728): I sometimes find that room conversation continues, apparently from a single person, after keying command-W to close a room.

comment:9 Changed 10 years ago by Gurpartap Singh

  • Cc gurpartap@… added
Note: See TracTickets for help on using tickets.