Opened 13 years ago

Closed 13 years ago

Last modified 20 months ago

#698 closed Defect (Invalid)

Default settings are annoyingly over the top, please tone it down a little

Reported by: AndySquirrel Owned by: timothy
Component: Colloquy (Mac) Version: 2.0 (Mac)
Severity: Normal Keywords:
Cc:

Description

I suggest that the default settings be toned down a little, what I do when I first install Colloquy is:

  1. Turn off the sound effects for Member Joined Chat Room, Member Left Chat Room, Member Kicked from Room, Member promoted to operator etc. Only leave the sound effects on for private messages and when somone mentions me.
  1. Change Unhandled Event Message to Show event bubble but don't keep on screen until activated (some servers display a lot of messages on connect)
  1. Set emoticons to text only
  1. Change the colour of room members from orange to something easier on the eye, such as blue.

Change History (41)

comment:1 Changed 13 years ago by rinoa

  • Resolution set to invalid
  • Status changed from new to closed
  1. I use each of those features. Most people do. We're not changing it for one person.
  2. These are preferences for YOU to change. Don't like it, change them. Thats why they are PREFERENCES.
  3. We have more than one emoticon set for picky users. We can't make the default EVERYONES favorite. I use Standard, timothy uses text.
  4. Change your style. Customize your style. Edit the css.

All your complaints is customizable and can be changed. They are preferences. We're not setting htem for one users needs.

Also, this is not a defect. And this is not an enhancement request. This is un-necessary.

comment:2 Changed 13 years ago by Sean

Even though they are preferences and can be changed, they should have good defaults.

I don't agree with the other stuff, but you should really consider number 1 in my opinion. The sounds effects for member joined/left chat room get really annoying especially on larger servers. It's the first thing I turn off and I'm sure many people do the same.

comment:3 Changed 6 years ago by miminon@…

Still annoying.

comment:4 Changed 5 years ago by ElephantHunter

I use each of those features. Most people do. We're not changing it for one person.

Considering the volume of information running through popular IRC channels, I doubt most people enjoy being barraged with senseless sound notifications every few seconds. Do you have any sources for the claim that most people have sound notification enabled? I have a strong feeling that overall, you'll find the exact opposite... that people who use Colloquy the most will disable sound notifications.

Sound notifications are highly annoying in the context of IRC, and should not enabled by default. Please reopen this ticket.

comment:5 Changed 5 years ago by anonymous

Yep, first time using Colloquy. First 10 seconds "How the fuck do I turn that off!?", 2 minutes later: "I have to google this, I must be doing it wrong or something is broken, this is insane."

It's like landing on a website with music, WTF, are we in the 90s?

comment:6 Changed 5 years ago by anonymous

bump bump bump. Annoying.

comment:7 Changed 5 years ago by holycrap@…

Super Super Super Annoying. HOW do you disable the sounds?

comment:8 Changed 5 years ago by anonymous

HOW THE FUCK DO I MAKE THE SOUNDS STOP?!?

comment:9 Changed 5 years ago by zach

Preferences -> Alerts -> Check the box that says "Mute all notification sounds"

comment:10 Changed 5 years ago by anonymous

Thanks @ zach - really missed to spot the drop down list prior you pointed me there to look again.

comment:11 Changed 5 years ago by anonymous

I agree with the comments about notifications being annoying.

Especially the "swatting" sound that happens everytime someone joins a room, extremely annoying.

I can understand other notifications I am not aware of being on by default.

However, there is a REAL CASE FOR TURNING OFF "NEW MEMBER JOINING ROOM" notifications by DEFAULT.

Thanks @ zach for the simple instructions for turning off all notifications. Pointed me to exactly the right location.

comment:12 Changed 5 years ago by zsolt.ero@…

I just want to comment that the default settings should be "mute everything" by default. I think making any kind of noise is super annoying/childish, especially when you have just started using the software in an office environment.

I got so angry at Colloquy that I've uninstalled it immediately, and only installed it again a few days later when I realised that all other clients are not comparable. This time I googled it till I found how can I mute all notifications.

In my opinion, a minimalistic, elegant software should not make any noise by default.

comment:13 follow-up: Changed 5 years ago by zsolt.ero@…

I just want to comment that the default settings should be "mute everything" by default. I think making any kind of noise is super annoying/childish, especially when you have just started using the software in an office environment.

I got so angry at Colloquy that I've uninstalled it immediately, and only installed it again a few days later when I realised that all other clients are not comparable. This time I googled it till I found how can I mute all notifications.

In my opinion, a minimalistic, elegant software should not make any noise by default.

comment:14 Changed 5 years ago by anonymous

I found this page because I'm trying to figure out how to turn that stuff off.

comment:15 Changed 5 years ago by anonymous

Playing sounds / making noises by default is Not Polite in a modern application.

comment:16 Changed 5 years ago by anonymous

Just installed Colloquy, immediately had to look for how to turn off the sound.

comment:17 Changed 5 years ago by anonymous

Same, just installed Colloquy 15min ago and had to Google to find how to disable these annoying sound notifications, and was very displeased by how the OP was bashed on bringing up a very obvious flaw of the software.

And yes, I had seen the "Mute all notifications" checkbox, but I dont want to mute ALL notifications, I just want to mute the public notifications (I DO want notifications when people message me or mentions me).

comment:18 Changed 5 years ago by Seamus

"Mute all sounds" is not a real answer to this bug. I imagine a lot of people would like to get a sound cue when they are mentioned. That sound notification should perhaps be on by default but nothing else.

comment:19 Changed 4 years ago by anonymous

+1 for super annoying

comment:20 Changed 4 years ago by anonymous

yep, totally annoying

comment:21 Changed 4 years ago by vax@…

I simply don'r get why this is on by default. Does not add any value. Or does it?

comment:22 Changed 4 years ago by anonymous

+1 for the complaint that the swatting sound is super annoying. It should be disabled by default.

comment:23 Changed 4 years ago by roger ramjet

yep.
very annoying :)

comment:24 Changed 4 years ago by anonymous

+1 for this. had to google how to turn it off. and now i can't find options to individually turn off certain sounds

comment:25 Changed 4 years ago by rawrgulmuffins

Continuing the chorus.

comment:26 Changed 4 years ago by anonymous

Apparently 9 years later the verdict is still fucking annoying. You'd think by the sheer amount of comments on here that programmer wouldn't be so attached to their views.

comment:27 Changed 4 years ago by markcbordelon@…

rinoa, the programmer, has probably been fired for his sounds, and now its just been forgotten.
installed colloquy, immediately durned off all sounds

comment:28 Changed 4 years ago by anonymous

Very Annoying

comment:29 Changed 4 years ago by dr2chase@…

If this is not a bug, then I am not going to use this app.
Was also not immediately obvious how to turn them off (that is why I am here).
I have still not found how to turn off the distracting noises.

comment:30 Changed 3 years ago by anonymous

Massively annoying defaults.

comment:31 Changed 3 years ago by anonymous

Hard to beleive this STILL has not been remedied. He said he doesn't want to change it for one user, but seems more he doesn't want to change it because he is the4 ONLY person who thinks it'snot annoying default to hear 100 people enter/leave a chatropom

comment:32 Changed 3 years ago by some irc bloke

Agreed. Thankfully there's other clients around. By default you're getting a join/left room sound jungle : awesome, if you're hyperactive

comment:33 Changed 3 years ago by some-irc-bloke

Agreed. Thankfully there's other clients around. By default you're getting a join/left room sound jungle : awesome, if you're hyperactive

comment:34 Changed 3 years ago by anonymous

SO ANNOYING

comment:35 Changed 2 years ago by anonymous

How they STILL haven't listened to this unanimous feedback is unreal.

comment:36 Changed 2 years ago by anonymous

the worst

comment:37 Changed 2 years ago by anonymous

is there a way to keep private messages / mention sounds enabled and the rest disabled ?
super annoying sounds btw....

comment:38 Changed 2 years ago by anonymous

agree with everyone here, however i think the MAIN issue is the joining/leaving room sounds by default. turn those off by default, the rest of the sounds can stay and users can google how to turn them off if needed.

comment:39 in reply to: ↑ 13 Changed 2 years ago by effrain

Replying to zsolt.ero@…:

I got so angry at Colloquy that I've uninstalled it immediately, and only installed it again a few days later when I realised that all other clients are not comparable.

As a fellow Mac user, I thought I was stuck with Colloquy too... Until I found Textual. It's vastly superior to this Colloquy BS. Unfortunately, it costs $6 USD, but there is at least a 30 day free trial. Try it! Once you realize how much less frustrating it is than Colloquy, you can dig around and find a free copy of it somewhere on the web. I, for one, will never go back.

ESPECIALLY after reading that arrogant "god-mod" reply to this original ticket that 'rinoa' wrote. No way am I ever going to support a project with developers like that on board.

comment:40 Changed 20 months ago by anonymous

I was also frustrated by this, but to turn it off:

  1. Go to preferences (Cmd-,)
  2. Click on the Alerts tab
  3. Click on the dropdown next to Chat Event
  4. Change it to "Member Joined Chat Room" and deselect "Play Sound"
  5. Change it to "Member Left Chat Room" and deselect "Play Sound"

It's up to the developers to make the software --- they are not beholden to anyone. If only this information was easier to Google...

I do think we should use free/libre software wherever possible, especially with IRC.

comment:41 Changed 20 months ago by anonymous

It's still an annoying default

Note: See TracTickets for help on using tickets.