Opened 12 years ago

Closed 10 years ago

#640 closed Defect (Fixed)

Colloquy seems to forget the nickserv password (was: Identify on irc.azzurra.org)

Reported by: AdamWest Owned by: akempgen
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Trivial Keywords: nickserv password identify
Cc:

Description

Sometimes the server don't identify me with the usually /identify password or when I am connected to the server.
But it always identify me with the /msg nickserv identify password "primitive" code.

Change History (11)

comment:1 Changed 12 years ago by akempgen

  • Component changed from Colloquy (GUI) to Chat Core (IRC)
  • Resolution set to fixed
  • Status changed from new to closed

make sure you really have the latest nightly, because [3227] should have fixed this and it should therefore work with the 5/11 Beta (2D41)...

comment:2 Changed 12 years ago by AdamWest

  • Resolution fixed deleted
  • Status changed from closed to reopened

Yes, i got the lastest nightly. Sometimes the "auto-join info" of the irc.azzurra.org server get lost and the password set into the general info don't run correctly, infact the server don't identify me.

comment:3 Changed 12 years ago by rinoa

Can you please show what happens? Open the console before connection and comment with what is sent to NickServ? or what NickServ? says.

comment:4 follow-up: Changed 12 years ago by AdamWest

{{{AdamWest? MODE +ix
NickServ? NOTICE This nick is registered. Please choose another one.
NickServ? NOTICE If it's yours, identify yourself with /ns IDENTIFY password
NickServ? NOTICE 20 seconds remaining before your nick's automatical change.
NickServ? NOTICE Your nick changed because AdamWest? it's a registered nick.
AdamWest? NICK}}}

This appen when i don't insert "/msg nickserv identify password" on the Automatic-commands box of the irc.azzurra.org server's info; but i set the right password on the apposite box...

comment:5 Changed 12 years ago by akempgen

  • Keywords nickserv password added
  • priority changed from normal to high
  • Severity changed from critical to normal
  • Summary changed from Identify on irc.azzurra.org to Colloquy seems to forget the nickserv password (was: Identify on irc.azzurra.org)

#680 is a duplicate of this one i guess...:

On connecting to an IRC server with a nickserv protected nick, I am prompted for my nickserv password, but it never actually authenticates me. If I tell it to save to keychain it does (and I no longer see the prompt on connect).
I can get around this by adding a command to the Automatic settings for the server.
First encountered this on 2D41, but "Version 2.1 (3264)" is the same.

comment:6 Changed 12 years ago by akempgen

  • Component changed from Chat Core (IRC) to Colloquy (GUI)

comment:7 Changed 11 years ago by etherflan

  • Severity changed from normal to major
  • Version changed from Latest Nightly to Latest 2.1

comment:8 Changed 10 years ago by Rinoa

  • milestone set to Colloquy 2.3

comment:9 in reply to: ↑ 4 ; follow-up: Changed 10 years ago by akempgen

  • Owner changed from timothy to akempgen
  • Status changed from reopened to new
  • Version changed from 2.1 (Mac) to 2.2 (Mac)

Replying to AdamWest:

NickServ NOTICE This nick is registered. Please choose another one.
NickServ NOTICE If it's yours, identify yourself with /ns IDENTIFY password
NickServ NOTICE 20 seconds remaining before your nick's automatical change.
NickServ NOTICE Your nick changed because AdamWest it's a registered nick.

this error notice currently falls through our grid of "nickserv" + "id", fix is on the way

comment:10 in reply to: ↑ 9 Changed 10 years ago by akempgen

  • Severity changed from Major to Trivial
  • Status changed from new to assigned

Auto identification on azzurra was fixed in [4164] and [4177].

Replying to akempgen:
Minor issue that still needs work.

comment:11 Changed 10 years ago by akempgen

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [4186].

Note: See TracTickets for help on using tickets.