Opened 14 years ago

Closed 14 years ago

#626 closed Defect (Fixed)

Colloquy needs to support CTCP VERSION during connect. (was: Problems with client response on last daily 2D40, according to sorcery.net)

Reported by: tigressesuede@… Owned by: timothy
Component: Chat Core (IRC) Version: 2.2 (Mac)
Severity: Blocker Keywords: ctcp version connect
Cc:

Description (last modified by akempgen)

Connecting to Sorcery.net, I get:

:shire.sorcery.net NOTICE AUTH :*** Your IRC software has failed to respond properly to the client check.
:shire.sorcery.net NOTICE AUTH :*** Try turning off or uninstalling any software addons or scripts you may be running and try again.
:shire.sorcery.net NOTICE AUTH :*** If you still have trouble connecting, then please see: http://www.sorcery.net/help/connecting.html
ERROR :Closing Link: BritneySpears[83.109.169.153] (Connection setup failed)

Change History (7)

comment:1 Changed 14 years ago by akempgen

  • Component changed from Colloquy (GUI) to Chat Core (IRC)
  • Description modified (diff)

comment:2 Changed 14 years ago by akempgen

I found this in sorcery.net's FAQ:

Disconnected with "Client check failed"
To keep certain malicious trojans and bots from connecting we request a CTCP VERSION from all connecting clients. If your client does not respond to this, it will be disconnected with a "Client check failed" message. Try to disable any client scripts that might filter CTCP requests and try again. For the clients listed below, support was added recently and you need the listed version or newer to pass the check.

http://www.sorcery.net/index.php?option=com_content&task=view&id=52&Itemid=378

comment:3 Changed 14 years ago by akempgen

i also asked them about it (using their web based client), and they added:

<Milambar> akempgen, it needs to support version during the connect phase. Its been my experience that a lot of mac osX based clients ignore ctcp versions until the connection is complete

comment:4 Changed 14 years ago by akempgen

  • Keywords ctcp version connect added
  • Summary changed from Problems with client response on last daily 2D40, according to sorcery.net to Colloquy needs to support CTCP VERSION during connect. (was: Problems with client response on last daily 2D40, according to sorcery.net)

comment:5 Changed 14 years ago by timothy

This should already work...

comment:6 Changed 14 years ago by Charles Miller

I just tried to connect to SorceryNet? using the June 8 nightly, and it still doesn't make it through the connect-phase checks. The stable release connects fine.

comment:7 Changed 14 years ago by timothy

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [3289]. Will be working in the next beta.

Note: See TracTickets for help on using tickets.