Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#524 closed Defect (Duplicate)

protected and owner user modes / prefixes not supported

Reported by: tehnick@… Owned by: timothy
Component: Chat Core (IRC) Version: 2.2 (Mac)
Severity: Critical Keywords: protected owner user mode prefix
Cc:

Description

Would it be a hassle to have some kind of identifier in the user list that shows protect status? (+a) I see there are colors for voice, half-op, op, but no protect. Something for owner would be nice aswell.

Change History (4)

comment:1 Changed 13 years ago by timothy

What is protect mode? What servers supports this?

comment:2 Changed 13 years ago by tehnick@…

It protects a user from ops (kick,bans,etc), but has limited priviledges.

/protect [on|off|nickname|address] Toggles protection of a nick or
address or sets it on or off totally.

It's usermode 'a', XChat signifies it with a red sphere and above all
but owner. I'm not sure specifically what servers support it because I
go to a lot of personal IRC servers, most running UnrealIRCd, but most
servers support it(I think).

Also, I mentioned something for owner (usermode q), there is no
indicator for that either. XChat indicates owner with a purple sphere
if it's of any help.

comment:3 Changed 13 years ago by timothy

  • Resolution set to duplicate
  • Status changed from new to closed

Marking this a duplicate of #606, it has more information.

comment:4 Changed 13 years ago by timothy

Fixed in [3224].

Note: See TracTickets for help on using tickets.