Opened 13 years ago

Closed 11 years ago

Last modified 10 years ago

#502 closed Defect (Works for Me)

paste error if the irc copied text is spanned on several lines

Reported by: pieggibo@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.0 (Mac)
Severity: Normal Keywords: paste, irc, ?~@~K, ~@~, ~@~K, bash, shell, vi
Cc:

Description

I spoke with nightstalker on irc chat before submitting this
On freenode's #freenet channel we exchange each other refs to test the new version.
The ref contains at least one line that is longer than the colloquy window, so the text is spanned on several GUI lines.
The problem is that copying the lines (included the long line) and pasting them in bash shell on into vi editor gives spaces or strange chars, as you can see in those pictures:
1) Here you can see how shell recognizes the "identity" field (the longer of all freenet ref fields).
On the first line you see it as is pasted to shell from colloquy, with apparently nothing strange. In the middle of the image you see how the shell recognizes the string, with the spaces placed exactly where the string is spanned in colloquy window:

http://img102.imageshack.us/img102/1923/image12xr.png

2) Here is seen the colloquy chat window where the text is copied from.
I pasted the copied text in a new vi window (the file was new, it wasn't already on disk): Note the strange string that appears in blue, always in correspondence of line breaks, "?~@~K". I think is the corresponding of line break in colloquy

http://img102.imageshack.us/img102/4706/image24kv.png

My colloquy version is 2D16, i have the DecafBland? Standard style.
The (default) encoding is set for all chats (verified) to Western (ISO Latin 1), that i think is the same of ISO-8859-1.
I'm available for more questions about this.
pieggi

pieggibo (ta) yahoo dot it

Change History (2)

comment:1 Changed 13 years ago by pieggi

I forgot to say that there are similar tickets about pasting errors, and the first one seems to be related to my problem:

#285 http://project.colloquy.info/trac/ticket/285
#321 http://project.colloquy.info/trac/ticket/321

thanks
pieggi

comment:2 Changed 11 years ago by akempgen

  • Resolution set to worksforme
  • Status changed from new to closed

can't reproduce with Colloquy 2.1 (3748) and Safari 3.0.3 (522.12.1).

Note: See TracTickets for help on using tickets.