Opened 14 years ago

Closed 13 years ago

#461 closed Enhancement (Duplicate)

Can't add the same server with different ports

Reported by: h3h <bfults@…> Owned by: timothy
Component: Colloquy (Mac) Version: 2.0 (Mac)
Severity: Normal Keywords:
Cc:

Description

It's a perfectly valid use case to want to have two servers, server.com:3333 and server.com:3334 (such as for a BNC). If one tries to add a server with the same address as one that already exists, no new server is added.

Change History (2)

comment:1 Changed 14 years ago by wac+colloquy@…

  • Type changed from defect to enhancement

Just to take this a little further... when using dircproxy you can have two servers on the exact same port, but a different password makes it bind to a different proxied connection. Right now you can kind of fake it with lots of CNAME/A records in DNS, but handling this natively would be a happier solution.

I'd call this an enhancement because it is just adding compatibility for those using proxied links which isn't the nominal use case for IRC (at least right now).

comment:2 Changed 13 years ago by timothy

  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #550 and #52 and is now fixed in [3520].

Note: See TracTickets for help on using tickets.