Opened 14 years ago

Closed 14 years ago

#457 closed Defect (Fixed)

silc connections do not automatically reconnect on wake from sleep

Reported by: pjenvey@… Owned by: patw
Component: Chat Core (SILC) Version: 2.2 (Mac)
Severity: Minor Keywords:
Cc:

Description

I use Colloquy to connect to both a normal IRC server and a SILC server, both with channel auto joins. Most nights I'll close the lid to the powerbook, and reopen it in the morning -- the IRC connections will automatically reconnect immediately on wakeup, yet the SILC connections do not

The SILC connection will reconnect eventually, but it usually takes maybe 30 - 45 minutes. I usually disconnect the silc connection manually in the connections window, or totally restart colloquy to reconnect. I believe also typing into the SILC window will cause it to notice it's disconnected

This is on 2D32, but the nightlies have been doing this for a while now. It used to work fine (maybe over 6 months ago)

Change History (4)

comment:1 Changed 14 years ago by pjenvey@…

I've attached a patch to solve this

The problem is MVSILCChatConnection overrides MVChatConnection's _systemWillSleep. The overriding method doesn't do anything, it only contains commented out code that would attempt to use the SILC DETACH feature, but it appears to be unfinished

Supporting the DETACH feature in the future would be great (although I think it should be an optional per server setting -- some would rather not use DETACH as it will drop any private messages detached clients receive)

comment:2 Changed 14 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 14 years ago by timothy

  • Resolution fixed deleted
  • Status changed from closed to reopened

This should not be closed yet, I will land this patch. Thanks!

comment:4 Changed 14 years ago by timothy

  • Resolution set to fixed
  • Status changed from reopened to closed

I guess this was fixed in [3218].

Note: See TracTickets for help on using tickets.