Opened 13 years ago

Closed 13 years ago

#377 closed Defect (Fixed)

Colloquy hung trying to change nick. Probably walking off memory and about to crash...

Reported by: colloquy@… Owned by: timothy
Component: Chat Core (IRC) Version: 2.2 (Mac)
Severity: Major Keywords:
Cc:

Description

here is the hang (crash?):

Analysis of sampling pid 4206 every 10.000000 milliseconds
Call graph:

895 Thread_0f1f

895 start

895 _start

895 main

895 NSApplicationMain

895 -[NSApplication run]

895 -[NSApplication sendEvent:]

895 -[NSWindow sendEvent:]

895 -[NSTextView keyDown:]

895 -[MVTextView interpretKeyEvents:]

895 -[JVDirectChatPanel textView:returnKeyPressed:]

895 -[JVDirectChatPanel send:]

895 -[MVIRCChatConnection sendRawMessage:immediately:]

895 irc_send_cmd_full

895 g_slist_append

895 g_slist_append

895 Thread_1003

895 _pthread_body

895 forkThreadForFunction

895 -[NSUIHeartBeat _heartBeatThread:]

895 -[NSConditionLock lockWhenCondition:]

895 pthread_cond_wait

895 semaphore_wait_signal_trap

895 semaphore_wait_signal_trap

895 Thread_1103

895 _pthread_body

895 forkThreadForFunction

895 +[NSURLConnection(NSURLConnectionInternal) _resourceLoadLoop:]

895 CFRunLoopRunSpecific

895 CFRunLoopRun

895 mach_msg

895 mach_msg_trap

895 mach_msg_trap

895 Thread_1203

895 _pthread_body

895 CFSocketManager

895 select

895 select

895 Thread_1303

895 _pthread_body

895 forkThreadForFunction

895 +[NSURLCache _diskCacheSyncLoop:]

895 CFRunLoopRunSpecific

895 CFRunLoopRun

895 mach_msg

895 mach_msg_trap

895 mach_msg_trap

895 Thread_1403

895 _pthread_body

895 forkThreadForFunction

895 +[MVIRCChatConnection(MVIRCChatConnectionPrivate) _irssiRunLoop]

895 g_main_iterate

895 g_hook_next_valid

895 g_hook_next_valid

895 Thread_1503

895 _pthread_body

895 forkThreadForFunction

895 +_syncLoop:?

895 -[NSRunLoop run]

895 -[NSRunLoop runMode:beforeDate:]

895 CFRunLoopRunSpecific

895 CFRunLoopRun

895 mach_msg

895 mach_msg_trap

895 mach_msg_trap

895 Thread_1603

895 _pthread_body

895 CAPThread::Entry(CAPThread*)

895 HALRunLoop::OwnThread?(void*)

895 CFRunLoopRunSpecific

895 CFRunLoopRun

895 mach_msg

895 mach_msg_trap

895 mach_msg_trap

Total number in stack (recursive counted multiple, when >=5):

7 _pthread_body
5 forkThreadForFunction

Sort by top of stack, same collapsed (when >= 5):

mach_msg_trap 3580
g_hook_next_valid 895
g_slist_append 895
select 895
semaphore_wait_signal_trap 895

Change History (1)

comment:1 Changed 13 years ago by rinoa

  • Resolution set to fixed
  • Status changed from new to closed

Can't reproduce. Likely fixed with the new chat core.

Note: See TracTickets for help on using tickets.