Opened 14 years ago

Closed 14 years ago

Last modified 11 years ago

#374 closed Enhancement (Duplicate)

Ghost support plugin

Reported by: colloquy@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Normal Keywords: nickserv ghost
Cc:

Description

Things such a plugin could include:

  1. automatic ghosing support (support for automatically retrieving your nick for you, or at least throwing up a popup)
  2. Support for disabling "block private messages from unregistered nicks"

I'm sure there are lots of other freenode specific optimizations which could be made.

I guess I'm just very supportive of "optimize for the common case", in this case, it seems to me that a large chunk of Software development IRC traffic flows through freenode... would make sense to improve the freenode experiance even further. Having a place to put thse sort of improvements would be a good start.

Change History (4)

comment:1 Changed 14 years ago by Rinoa <emily@…>

  • Summary changed from Colloquy needs a FreeNode specific plugin to Ghost support plugin
  1. /msg NickServ? SET UNFILTERED {ON|OFF} to turn blocking of private messages form unregistered nicks on or off. You want this option ON to recieve the private messages. You only need to do this once.

comment:2 Changed 14 years ago by Rinoa <emily@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate: 1. Ok, I just noticed that the ghost support half is a duplicate of #271 which states:
"Ideally, Colloquy should be smart enough to talk to NickServ? and recover my nick automatically for me, if I tell it to."
So I'm closing this one now.

comment:3 Changed 13 years ago by akempgen

  • Component changed from General Script Support to Third-Party Plugin
  • Keywords nickserv ghost added
  • Type changed from task to enhancement
  • Version changed from 2.0 (2D16) to Latest Nightly

comment:4 Changed 11 years ago by etherflan

  • priority changed from normal to high
Note: See TracTickets for help on using tickets.