Opened 14 years ago

Closed 13 years ago

Last modified 5 years ago

#322 closed Defect (Duplicate)

The transcript file file shows only todays transcripts

Reported by: sverrehelge@… Owned by: timothy
Component: Chat Core (IRC) Version: 2.0 (Mac)
Severity: Normal Keywords:
Cc:

Description

I have enabled "one folder for each server" and "multiple session in one file". When I open the transcripts it only shows todays transcripts ,but the transcriptfile is 8mb and was created 2 months ago. How do I view all the sessions that is stored in this file ?
In other iIRC clients (x-chat) it only loads a certain bit of the log file, but there is a also button to load all of the file.

Change History (3)

comment:1 Changed 14 years ago by timothy

  • Status changed from new to assigned

This is currently a limitation I am looking to resolve. The WebKit? view will get overloaded if we try to show too much info in it. I have no good solution for you. But you can analize the XML of the transcript. Or use this XSL file to convert it to a text based output.

http://colloquy.info/downloads/plainText.xsl

Use it in the Terminal like:
xsltproc /Users/Timothy/Desktop?/plainText.xsl /Users/Timothy?/test.colloquyTranscript

This problem is high on my list to fix.

comment:2 Changed 13 years ago by timothy

  • Resolution set to duplicate
  • Status changed from assigned to closed

This should be a dupe of #109. Known issue I am working to fix soon.

comment:3 Changed 5 years ago by mauritslamers@…

The conversion to plain text from the transcript should be mentioned in the FAQ!

2.4.2 still cannot display the entire transcript, only a subset. I found quite a few tickets describing the same issue (#865 #1986 and #2060, which all marked duplicate of the empty transcript issue #576)

Note: See TracTickets for help on using tickets.