Opened 14 years ago

Closed 13 years ago

#319 closed Defect (Fixed)

join dialog does not show, if connected but no room was joined and the connections are not shown

Reported by: adam@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Minor Keywords: join room dialog menu item
Cc: adam@…

Description (last modified by akempgen)

I have a single connection configured and set to auto-connect. I launch the app, it connects. I hit Cmd-J, and connection pop-up has nothing selected. Minor UI annoyance.

join dialog does not show, if connected but no room was joined and the connections are not shown (= no windows open). cmd-j only blinks the menu.

Change History (16)

comment:1 Changed 14 years ago by timothy

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [2907].

comment:2 Changed 14 years ago by adam@…

  • Cc adam@… added
  • Resolution fixed deleted
  • Severity changed from minor to normal
  • Status changed from closed to reopened

As of 2D28, hitting Cmd-J now does nothing at all. Menu just blinks. Joining a room from the Connections dialog still works.

comment:3 Changed 14 years ago by adam@…

2D30 is still showing this behavior.

comment:4 Changed 14 years ago by Rinoa

I am able to reproduce this. It appears that the Cmd+J doesn't work only when you have the connections window as the active window, and no server selected. It has normal behaviour when a server is selected or you have a chatroom/console as the active window.

comment:5 Changed 14 years ago by adam@…

If the connection window is not showing at all, but I am auto-connected, nor Cmd-J nor selecting the command from the menu work.

comment:6 Changed 14 years ago by anonymous

adam@… - I just tested with latest build and it works fine here. One server, auto-connected, connections window was never shown.

comment:7 Changed 14 years ago by adam@…

I'm using nightly, problem is still here. Maybe it is related to a configuration element?

comment:8 Changed 14 years ago by anonymous

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in [3004].

comment:9 Changed 14 years ago by steven@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

I don't think the latter issue was fixed. I'm seeing exactly the same issue as adam@… in 2D38. Colloquy has auto-connected, no windows are open. Hitting ⌘J just blinks the menu item.

The shortcut works if you open the connections window or after joining at least one channel. It started appearing for me after upgrading to the latest nightly.

comment:10 Changed 14 years ago by adam@…

Thanks for adding to this ticket, I also still have the problem. Not running 2D38 yet, I'll do that.

comment:11 Changed 14 years ago by anonymous

I can confirm that the behaviour is still present under 2D38.

comment:12 Changed 14 years ago by adam@…

Having a second connection setup, seems to fixe the issue. i.e. I now have two connections and Cmd-J brings up the join dialog with the second connection selected by default. Hope this helps!

comment:13 Changed 13 years ago by adam@…

I can confirm that the problem is resolved.

comment:14 Changed 13 years ago by akempgen

  • Description modified (diff)
  • Keywords join room dialog menu item added
  • priority changed from normal to low
  • Severity changed from normal to minor
  • Summary changed from Connection to be Selected In Join Dialog to join dialog does not show, if connected but no room was joined and the connections are not shown
  • Version changed from Latest Nightly to Latest 2.1

no its not. the problem persists in r3321 and probably later versions, too.

comment:15 Changed 13 years ago by Rinoa

This works for me. Is it still an issue, akempgen?

comment:16 Changed 13 years ago by Rinoa

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in [3394]

Note: See TracTickets for help on using tickets.