Opened 13 years ago

Closed 10 years ago

#302 closed Defect (Works for Me)

New/Connect button bug in the 'Connections' window.

Reported by: cryo@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Normal Keywords: connections window
Cc:

Description

When Colloquy start up without opening the 'Connections' window, and you then, after launch, open it manually using cmd-1, and if you do that -too fast- (before the program is done initialising or whatever), the bug is triggered.

Then, the button 'New' which normally changes to 'Connect' when you select a previous connection, will not do so and stay 'New', and act as it as well. This makes it impossible to connect to previous connections. The fix is usually to restart the app, and be a little slower on the cmd-1 the second time. I take it it's a race condition somewhere.

Change History (1)

comment:1 Changed 10 years ago by Rinoa

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce. Is this still an issue?

Note: See TracTickets for help on using tickets.