Opened 15 years ago

Closed 14 years ago

#30 closed Defect (Fixed)

Messages arriving soon after panel opens are lost

Reported by: kpreid@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Major Keywords:
Cc:

Description

When I start up Colloquy, messages arriving while Colloquy is creating the channel panels and during the initial hang-after-startup often do not show up at all in the panel. (The drawer activity icons do appear.)

I have private message panels set to show up in new windows. Nearly every time I receive a private message without having a panel open for the sender already, it does not show up.

I use the Bland style. /reload style does not cause the messages to appear.

Mac OS X 10.3.8, 500 MHz G3, 320MB memory, Colloquy 2/25 nightly, Safari 1.2.4 (v125.12)

Change History (7)

comment:1 Changed 15 years ago by timothy

  • Status changed from new to assigned

If /reload style dosen't work, then there is another problem other than WebKit? not being ready. hmmm..

comment:2 Changed 15 years ago by timothy

Can you verify this with the latest nightly?

comment:3 Changed 15 years ago by david@…

Version 2.0 (2D16)

I have the same behaviour in Colloquy as kpreid. Just wants to add the below.
When users query me and write me in private I do not see their first few lines. If I type something to them I see everything they type afterwards, but if not I may miss upto three inputs from their behalf.

Had a friend paste me some sql-data and I got the last 4 lines of it but missed the first 9, and it all was in one input from his side.

It doesn't help by using /reload or switching styles either.

comment:4 Changed 14 years ago by Darien

  • Version changed from 2.0 (2D9) to Latest Nightly

From experimentation it has been determined that this bug is related to the user's specific preferences file, and not the user's versions of OS X, Colloquy, etc, or the user's hardware. Removing/renaming the cc.javelin.colloquy.plist file from ~/Library/Preferences? and re-configuring Colloquy may solve the issue.

comment:5 Changed 14 years ago by Darien

Bug #4 has been marked as a duplicate of this one

comment:6 Changed 14 years ago by anonymous

Bug #4 isn't related.

comment:7 Changed 14 years ago by timothy

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [2976]. Thanks kpreid!

Note: See TracTickets for help on using tickets.