Opened 8 years ago

Closed 7 years ago

#2972 closed Defect (Fixed)

OperationalError: database is locked

Reported by: Computers57@… Owned by: Rinoa
Component: Web Site Version: 2.3 (Mac)
Severity: Blocker Keywords:
Cc: Computers57@…

Description

How to Reproduce

While doing a GET operation on /login, Trac issued an internal error.

My attempts at logging in and adding more info to a ticket (#2971) have been in vain. Please fix this issue so I can help debug this issue.

User Agent was: Mozilla/5.0 (iPad; CPU OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3

System Information

Trac 0.11.4
Python 2.4.3 (#1, Sep 21 2011, 20:06:00)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-51)]
setuptools 0.6c5
SQLite 3.3.6
pysqlite 2.6.0
Genshi 0.5
Subversion 1.6.16 (r1073529)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 435, in _dispatch_request
    dispatcher.dispatch(req)
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/web/auth.py", line 101, in process_request
    self._do_login(req)
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/web/auth.py", line 140, in _do_login
    "VALUES (%s, %s, %s, %s)", (cookie, remote_user,
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/db/sqlite_backend.py", line 58, in execute
    args or [])
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked


Change History (2)

comment:1 Changed 8 years ago by RichardLynch

  • priority changed from Normal to Highest
  • Severity changed from Normal to Blocker

I am also experiencing severe difficulties using colloquy.info at this time, due to frequent "database is locked" errors.

Happens in the Trac sub-system, and in login/register pages.

If the diagnostic above is indicating that you're using just sqllite behind this whole site, then that would be my first recommended change: Use an RDBMS instead.
MySQL, PostgreSQL, SQL Server, Oracle, whatever you like.
But something that's not strictly file-based like sqlLITE. LITE as in "Light Duty Only" :-)

comment:2 Changed 7 years ago by zach

  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.