Opened 13 years ago

Closed 10 years ago

#289 closed Defect (Fixed)

nick completer produces wrong results with nicknames containing \

Reported by: akempgen Owned by: timothy
Component: Colloquy (Mac) Version: Local Build
Severity: Normal Keywords: nick completer
Cc:

Description

if a nickname contains a \ nick completer produces wrong results

if my name is night\stalker, and there is someone else in the chan with a nick starting with "ni",
typing "ni" and several tabs produces stuff like "night\stalker\stalker\stalker"...

Change History (5)

comment:1 Changed 13 years ago by akempgen

still an issue, also happens if there are two persons "Rinoa" and "ri" and you type ri<tab>...

Ri\noa: \noa: \noa: \noa: \noa: \noa:
ri: : : : :

comment:2 Changed 12 years ago by akempgen

  • Reporter changed from nightstalker to akempgen

comment:3 Changed 12 years ago by akempgen

#349 is related

comment:4 Changed 10 years ago by Rinoa

  • milestone set to Colloquy 2.3

comment:5 Changed 10 years ago by akempgen

  • Resolution set to fixed
  • Status changed from new to closed

can't reproduce this anymore with 2.2.1 (4173), must have been fixed at some point.

Note: See TracTickets for help on using tickets.