Opened 14 years ago

Closed 14 years ago

#265 closed Defect (Fixed)

add missing charsets to encoding menus

Reported by: rq@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Normal Keywords: patch
Cc:

Description

Colloquy is missing a few charsets in its encoding dropboxes.

namely, i'm missing the group of Baltic character sets - windows-1257 aka "Baltic (Windows)" and ISO-8859-13 aka "Baltic (ISO Latin 7)". also, ISO-8859-4, which is now named "Central European" should indeed be called "Northern European (ISO Latin 4)" or "Baltic (ISO Latin 4)". Would be very cool if that were added & fixed.

You could also check if there are no other missing charsets, and add them if there are.

Change History (2)

comment:1 Changed 14 years ago by rq@…

  • Keywords patch added
  • Version changed from 2.0 (2D9) to Latest Nightly

i've patched the source of Colloquy a little, to help it support the charsets I mentioned. I've found out that the names of these charsets aren't defined in Colloquy, so that is no longer an issue. However, i've made a small regrouping, and moved ISO-8859-4 to the newly created group of Baltic charsets from the Central European group.

As far as i've tested, Colloquy seems to run just like before with this patch, so it should be safe to apply. The only thing i'm not sure about is why the two lines with "cp55" were missing in NSStringAdditions.m (look at the bottom of the patch). If that was intended, then maybe cp57 shouldn't be there too. However, if that was simply missed out, i've added those lines now.

comment:2 Changed 14 years ago by timothy

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [2893].

Note: See TracTickets for help on using tickets.