Opened 7 years ago

Closed 5 years ago

#2640 closed Defect (Works for Me)

Directed messages disappear in channel view

Reported by: justizin Owned by: timothy
Component: Colloquy (Mac) Version: 2.3 (Mac)
Severity: Blocker Keywords:
Cc:

Description

One feature of Colloquy that I've always enjoyed is its' ability to notify me visually when people in a channel mention my nick or words I specify as important.

I started using a new machine at a new job, where we communicate via IRC. Colloquy does notify when someone mentions me, e.g. by placing a second unread message count with a red background in the channel list.

Unfortunately, it also fails to display such messages in the channel view or transcript. Naturally, this creates a great deal of frustration in communication as any time communication is directed at me, I fail to receive it.

I've even had this problem discussing this bug in #colloquy on freenode, and have missed quite a few helpful responses from people in other channels. In most cases when communicating with people who are not my direct coworkers, this information is lost forever as they aren't particularly motivated to re-send communication.

Currently in order to meet my need to communicate on IRC I'm using a terminal-based client on a server of mine, but I'd really like to get Colloquy worked out.

I have used Colloquy for years and never seen this problem, and noone on #colloquy, nor any of my Colloquy-using coworkers appear to have ever observed this, but it is very real and creates a detrimental effect. The ability to see messages directed at me is relatively central to my needs in a chat client, naturally. :)

I tried using Colloquy on a fresh account on my Mac with all default settings - though my own account is also relatively fresh - and was able to reproduce this problem, so it is not due to any artifact of configuration on my account.

I have reproduced this on Colloquy 2.3, 2.2, and 2.1 - I thought it may be a new bug, so I regressed, but the same happens on all released versions I can find a download of.

Thanks in advance for the community's attention to this issue, and please let me know if there is any diagnostic or exploratory action I can engage.

Setting this as highest priority and severity: Blocker, as my ability to successful.

Change History (1)

comment:1 Changed 5 years ago by zach

  • Resolution set to Works for Me
  • Status changed from new to closed

Never seen this. Reopen with steps to reproduce, if this is still happening.

Note: See TracTickets for help on using tickets.