Opened 4 years ago

Closed 4 years ago

Last modified 7 months ago

#2590 closed Defect (Fixed)

Sasl support?

Reported by: Doooge@… Owned by: kiji.roshi
Component: Colloquy (iOS) Version: 1.3 (iOS)
Severity: Normal Keywords:
Cc:

Description

Hi, im attempting to connect to the freenode server using colloquy for iphone but it informs me that I dont have sasl support. Please let me know how I would do this or get sasl enabled.

here is the error I get:

pratchett.freenode.net: * Notice -- You need to identify via SASL to use this server

Change History (13)

comment:1 Changed 4 years ago by kiji.roshi

  • Resolution set to fixed
  • Status changed from new to closed

SASL support is fixed by [5259] and is being released in an update soon.

comment:2 Changed 4 years ago by theory

  • Resolution fixed deleted
  • Status changed from closed to reopened

Note that, while it will be nice to have SASL + Tor support, I don't think that was the issue the OP reported. I've run into the same error on Colloquy 2.3 for OS X, with a configuration I've been using for years. It seems that the issue is related to being on a mobile network -- I'm getting the error using a Virgin Mobile MiFi? connected to the Sprint network (or is it verizon? I've no idea). See this post for a bit more information. It may be a Freenode issue, rather than Colloquy. I'm not sure.

comment:3 Changed 4 years ago by zach

  • Resolution set to fixed
  • Status changed from reopened to closed

The fix applies to both Mobile and Desktop Colloquy. For now, you will have to build Colloquy from source if you wish to have SASL support.

comment:4 Changed 12 months ago by pawanspace@…

I have recently purchased colloquy on Iphone 4S. when I am on my cellular network. I get error SASL authentication failed. SASL access only. Is it not updated yet. I feel this is the same issue.

comment:5 follow-up: Changed 12 months ago by anonymous

i'm in the same boat this still isn't working for me.

comment:6 in reply to: ↑ 5 Changed 12 months ago by pawanspace

Replying to anonymous:

i'm in the same boat this still isn't working for me.

Solved it just go to network settings for example free node then go to advance options and off sasl option.

comment:7 Changed 9 months ago by anonymous

Turning off SASL doesn't work for me. I get:

ERROR Closing Link: xx.xx.xx.xx.mycingular.net (SASL access only)

Maybe this is AT&T specific, though I doubt it.

comment:8 Changed 9 months ago by anonymous

This doesnt work for me either.

comment:9 Changed 9 months ago by anonymous

Still doesn't work for me. It's frustrating.

comment:10 Changed 9 months ago by anonymous

agreed >_< would be nice if the app i paid for worked...

comment:11 Changed 9 months ago by zach

If you're connecting to Freenode, they have special instructions on how to use SASL: https://freenode.net/sasl/

For all other networks, it should Just Work already.

comment:12 Changed 7 months ago by jrhett@…

Turning on SASL support means enabling constant pain and annoyance. EVERY TIME I unlock my laptop (30x times a day) Colloquy asks me to reauthenticate. I can hit cancel, because it already has my credentials. The NickServ? log shows that I successfully re-authenticate every time even when I hit cancel, but

  1. The pop up demand comes up every time
  1. I'm yanked from whatever Space I'm working in to the Space where Colloquy is

comment:13 Changed 7 months ago by jrhett@…

Turning on SASL support means enabling constant pain and annoyance. EVERY TIME I unlock my laptop (30x times a day) Colloquy asks me to reauthenticate. I can hit cancel, because it already has my credentials. The NickServ? log shows that I successfully re-authenticate every time even when I hit cancel, but

  1. The pop up demand comes up every time
  1. I'm yanked from whatever Space I'm working in to the Space where Colloquy is

Add Comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.