Opened 9 years ago

Closed 9 years ago

#2567 closed Defect (Invalid)

NickServ identify does not work with an SSL connection

Reported by: kumar303 Owned by: timothy
Component: Colloquy (Mac) Version: 2.3 (Mac)
Severity: Normal Keywords:
Cc: kumar.mcmillan@…

Description

I'm trying to connect to irc.mozilla.org on port 6697 (recommended) as SSL with a registered nickname. I have the nick/password filled out in the info panel but every time I connect it says password not accepted. It pops up a password dialog so I re-enter it. Then the connection seems to freeze. I can see NickServ? IDENTIFY * in the console but nothing happens. If I type /ping irc.mozilla.org I get no response. This same exact thing happens every time.

However, when I uncheck SSL and put it back on port 6667 then the password protected nick works just fine.

Is this a firewall problem? I am using an Airport Express but I don't know what ports I need to open for this to work (if any).

Note also that I am using a server username/password when connecting with SSL. I tried removing this but I still get the same behavior.

This is similar to issue #640 but seems to be SSL related.

Change History (6)

comment:1 Changed 9 years ago by kumar303

  • Cc kumar.mcmillan@… added

Would it help if I ran a debug build or something to get some extra logging? It might be related to port communication. I turned on NAT/PnP on my Airport Extreme and huzzah that seemed to let me log in with ssl + password just fine. I noticed in my router logs that a binding opened up on port 30256 or something like that. However, I fired up Colloquy today after moving my laptop around (was online at another network) and now I'm having the same problems again. The connection just freezes up, pings don't come through. I even opened up all high level ports on my router but that does not seem to be helping. Maybe at this stage it is no longer port related. Or perhaps something is cached?

comment:2 Changed 9 years ago by kumar303

It would be really nice if Colloquy could report or log the errors it is encountering. I'm pretty sure my problems are related to port access.

When I wrote the comment above, my IP address had changed which is why NAT-PMP was not working. I fixed that by reserving an IP for my mac address and setting my dhcp to always use the right IP. d'oh. When I looked at netstat before fixing all this I saw a lot of un-established port connections.

After the IP fix and confirming the NAT connection in my router and after restarting my laptop, Colloquy seems to be working fine now. I now see this in netstat:

tcp4       0      0  10.2.21.114.49161      sand.mozilla.org.6697  ESTABLISHED

what the-? This isn't even my local IP address! I guess Colloquy is binding some daemon to a separate IP?

Anyway, it does appear to be working so far after I fixed my firewall. Again, it would be nice if Colloquy reported "could not bind to IP/port" or something.

comment:3 Changed 9 years ago by kumar303

Any ideas on this? I still see it hang anytime I reopen Colloquy after my laptop has gone to sleep or left and rejoined the network. I have scoured ps aux but I don't see any suspicious daemons. Is it perhaps my VPN and its routes? I don't know what Colloquy is doing when it hangs on IDENTIFY. The only way to fix it is to restart my machine. Then it works again.

In case it helps, I am attaching dtruss output when the UI shows that it is waiting for NICK IDENTIFY. Note that this is only for my ssl connection to irc.mozilla.org, I also have an active and working freenode connection while dtruss was logging.

Let me know if you need any other debug info.

I have tried about 6 other IRC programs but none of them offer SSL and registered nick support :(

comment:4 Changed 9 years ago by kumar303

Aha, I switched my VPN from Tunnelblick to Viscocity and so far IRC is working flawlessly. Huh.

comment:5 Changed 9 years ago by kumar303

arrgh. It worked at first but when I reopened Colloquy (after closing it) NickServ? IDENTIFY is back to hanging even with Viscosity VPN. This is definitely a VPN issue because when I disconnect from the VPN everything works fine.

comment:6 Changed 9 years ago by zach

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.