Opened 14 years ago

Last modified 10 years ago

#221 reopened Defect

should not autojoin channels after wake from sleep

Reported by: dmd@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Normal Keywords: sleep autojoin interrupt state status
Cc: grahamperrin

Description

If Colloquy is running when the computer is woken from sleep, and there are channels in the "automatic join rooms" list, those channels will automatically be joined upon waking. This is an unexpected behavior. It seems that a distinction should be drawn between active choices by the user (launching Colloquy or choosing to connect to a server) and secondary effects of things like waking from sleep.

Colloquy, upon waking from sleep, should seek to restore the condition it was in before sleep. I think this should be user selectable between two possibilities:

  1. Reconnect to all servers that were connected before going to sleep, but do NOT join channels.
  2. Reconnect, AND join channels which were open when the computer went to sleep.

Notice that NEITHER of these cases has anything to do with the state of Colloquy's autojoin/autoconnect preferences - what happens on waking should NOT have anything to do with what the user has asked Colloquy to do on initial launch! Waking should depend only on the status of Colloquy when it went to sleep.

Change History (6)

comment:1 Changed 14 years ago by timothy

  • Status changed from new to assigned

Part of this was fixed in [2754]. We should add a preference for this sort of thing. Some users also expect Colloquy to do the auto-commands and auto-joins every time the connection is established (the current behavior).

So there could be 2 preference choices:

  • Reconnect to servers that were connect before sleep and don't join any channels that were left open.
  • Reconnect and join all open channels.

There should also be a check box next to the auto-join list per connection that says: "Join only on first connect".
The auto-joins were never intended to only happen on launch only. This is really the first time I have heard someone wanting this behavior, but it has it's advantages.

comment:2 Changed 14 years ago by dmd@…

  • Version changed from 2.0 (2D16) to Latest Nightly

This behavior appears to have returned in 2D24.

comment:3 Changed 13 years ago by rinoa

  • Resolution set to wontfix
  • Status changed from assigned to closed

I think that if your computer falls asleep, when it wakes up, it should return to the exact state it was left in. Not going to fix.

comment:4 Changed 13 years ago by rinoa

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Aparently not fixed in 3290. Wake from sleep SHOULD either return to the state it's in, or close all open windows and start over with the auto-connect and join lists.

comment:5 Changed 10 years ago by grahamperrin

  • Cc grahamperrin added

comment:6 Changed 10 years ago by grahamperrin

  • Keywords interrupt state status added

See also

  • ticket:1205, Colloquy does not restore /away status after network interruptions
  • ticket:1206, add auto-/away-when-keyboard-and-mouse-idle option
  • ticket:1239, Sleep message.
Note: See TracTickets for help on using tickets.