Opened 9 years ago

Closed 7 years ago

#2133 closed Defect (Fixed)

Colloquy (Mobile) not saving various settings on iOS 4.0

Reported by: BTCentral Owned by: kiji.roshi
Component: Colloquy (iOS) Version: Local Build
Severity: Normal Keywords: Colloquy Mobile, Room Key, Server Port, Nick Pass
Cc: michelle.wright@…

Description

I have noticed the following problems with Colloquy (Mobile) SVN revision 5003 when setting up a new Connection:

  • If you enter an IRC Server Address, then go to Advanced, then press back, the Address disappears and needs to be re-entered (Work around: re-enter server address).
  • On "Join Rooms" if you enter add a room with a Room Key, and then go back, the key disappears and is not saved (Work around: none known).
  • Under Advanced Server port is not always saved.
  • Under Advanced Nick Pass. disappears if you go back into settings, and you seem to be unable to set it again.

Change History (4)

comment:1 Changed 9 years ago by BTCentral

Work around for Nick Pass. disappearing: Make sure you are disconnected from the server, enter password and then enter Username (even if it is the same as the default).

comment:2 Changed 9 years ago by shelluk

  • Cc michelle.wright@… added

I see numerous tickets have been closed saying they are a duplicate of this with the password randomly disappearing. So what's the fix? Re-entering it several times a day is not a fix.

How I see it (and others seeing various protests at tickets being closed as duplicates), is that there is a *separate* issue as addressed in BTCentral's reply above where you need to make sure you do certain things in a certain order for the password to be saved in the first place. This isn't the same problem as the password being there and working fine one minute, then when you go to use Colloquy again it's gone and refuses to connect until you re-enter it, again.

Come on guys. You explain we pay for this app for several reasons, including support. So please give it :)

Thanks
Shell

comment:3 Changed 9 years ago by _thekev

I am not having problems with nickserv password sticking, but server password disappears after device reboot (may start/stop application any number of times, just not reboot)

This has been confirmed on iPhone 4.1 an iPad 4.2.1. I have six server entries. All go away. I just tried setting them while disconnected, and we'll see if that workaround sticks.

comment:4 Changed 7 years ago by zach

  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.