Opened 13 years ago

Closed 12 years ago

#207 closed Defect (Duplicate)

Autojoining new channels switches to them

Reported by: astrange@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.0 (Mac)
Severity: Normal Keywords:
Cc:

Description

When Colloquy starts and automatically joins a new channel, it switches that channel and its text entry to the front, making it impossible to say anything until it's joined every channel (as otherwise your text will end up scattered over several different text boxes that happened to be switched).

Change History (3)

comment:1 Changed 13 years ago by Machina

  • Resolution set to fixed
  • Status changed from new to closed

This has been fine for a long time now, all you need to do is press and/or hold the command key while joining channels to make then join in the background as opposed to switching the active context to them. This works for rooms, and queries.

comment:2 Changed 12 years ago by colloquy

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening this ticket, because I do not see how that is a solution.

If you need to press/hold cmd, that basically means replacing the problem of having text input scattered with the problem of not being able to type at all (due to pressing cmd), until you've joined all channels.

My suggestion would be to open auto-joined channels in the background if you've started typing (i.e. if the text input box is non-empty). No settings clutter, no having to recall shortcuts, just sensible behavior. I can't see that anyone wouldn't want things to work this way.

comment:3 Changed 12 years ago by rinoa

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #112

Note: See TracTickets for help on using tickets.