Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#2063 closed Defect (Duplicate)

4.0b1 crash upon startup. Application cannot be used.

Reported by: tony@… Owned by: kiji.roshi
Component: Colloquy (iOS) Version: 1.1 (iOS)
Severity: Major Keywords: 4.0
Cc:

Description

Incident Identifier: 0AD27065-64D5-415C-98A4-5211D0668A1D
CrashReporter? Key: 4a4f4dc8c49dede99092f7bba6707ff174042ec8
Hardware Model: iPhone2,1
Process: Colloquy [242]
Path: /var/mobile/Applications/73707729-4869-4746-8C7E-A729102A9401/Colloquy.app/Colloquy
Identifier: Colloquy
Version: ??? (???)
Code Type: ARM (Native)
Parent Process: launchd [1]

Date/Time?: 2010-04-14 12:17:40.886 -0400
OS Version: iPhone OS 4.0 (8A230m)
Report Version: 104

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x00000008
Crashed Thread: 0

Thread 0 Crashed:
0 IOKit 0x000041be IONotificationPortGetRunLoopSource + 6
1 Colloquy 0x0003f830 0x1000 + 256048
2 Colloquy 0x0003f5fc 0x1000 + 255484
3 Colloquy 0x00003836 0x1000 + 10294
4 UIKit 0x000e08fc -[UIApplication _callInitializationDelegatesForURL:payload:suspended:] + 724
5 UIKit 0x000e1326 -[UIApplication _runWithURL:payload:launchOrientation:statusBarStyle:] + 194
6 UIKit 0x0003a1a0 -[UIApplication handleEvent:withNewEvent:] + 1364
7 UIKit 0x00039aee -[UIApplication sendEvent:] + 38
8 UIKit 0x0003961c _UIApplicationHandleEvent + 4764
9 GraphicsServices? 0x00003aae PurpleEventCallback? + 658
10 CoreFoundation? 0x0006aa88 CFRunLoopRun + 2504
11 CoreFoundation? 0x0001ddd0 CFRunLoopRunSpecific + 264
12 CoreFoundation? 0x0001dcb0 CFRunLoopRunInMode + 52
13 UIKit 0x000031ee -[UIApplication _run] + 362
14 UIKit 0x00001d68 UIApplicationMain + 632
15 Colloquy 0x00002ff0 0x1000 + 8176
16 Colloquy 0x00002f8c 0x1000 + 8076

Thread 1:
0 libSystem.B.dylib 0x00000848 mach_msg_trap + 20
1 libSystem.B.dylib 0x00002914 mach_msg + 44
2 CoreFoundation? 0x0006a4cc CFRunLoopRun + 1036
3 CoreFoundation? 0x0001ddd0 CFRunLoopRunSpecific + 264
4 CoreFoundation? 0x0001dcb0 CFRunLoopRunInMode + 52
5 WebCore? 0x0004fa3a RunWebThread?(void*) + 354
6 libSystem.B.dylib 0x0007947a _pthread_start + 242
7 libSystem.B.dylib 0x0006ed64 thread_start + 0

Thread 2:
0 libSystem.B.dylib 0x0002cbd8 kevent + 24
1 libSystem.B.dylib 0x000d5154 _dispatch_mgr_invoke + 88
2 libSystem.B.dylib 0x000d4d30 _dispatch_queue_invoke + 96
3 libSystem.B.dylib 0x000d4ed0 _dispatch_worker_thread2 + 120
4 libSystem.B.dylib 0x00079876 _pthread_wqthread + 258
5 libSystem.B.dylib 0x00072c4c start_wqthread + 0

Thread 3:
0 libSystem.B.dylib 0x0007a0e0 workq_kernreturn + 8
1 libSystem.B.dylib 0x00079994 _pthread_wqthread + 544
2 libSystem.B.dylib 0x00072c4c start_wqthread + 0

Thread 0 crashed with ARM Thread State:

r0: 0x00000000 r1: 0x3e426f78 r2: 0x3e39b5ce r3: 0x00000000
r4: 0x00146820 r5: 0x0008c464 r6: 0x0009b088 r7: 0x2fffe7bc
r8: 0x0008df5c r9: 0x34daf47a r10: 0x00107f00 r11: 0x000950c8
ip: 0x308de1b9 sp: 0x2fffe794 lr: 0x0003f837 pc: 0x308de1be

cpsr: 0x40000030

Binary Images:

0x1000 - 0x83fff +Colloquy armv7 <cb2953976f619002dd931022fdc96d4b> /var/mobile/Applications/73707729-4869-4746-8C7E-A729102A9401/Colloquy.app/Colloquy

0xc2000 - 0xc3fff dns.so armv7 <f5d01bd0f83b11b1c93001182ad0e4e9> /usr/lib/info/dns.so

0x2fe00000 - 0x2fe2afff dyld armv7 <bef7ae1cddc344beeba7486f7320bd69> /usr/lib/dyld
0x30005000 - 0x3017ffff MediaToolbox? armv7 <2ddd832d31d3e488e79c25cf69a351ce> /System/Library/PrivateFrameworks/MediaToolbox?.framework/MediaToolbox
0x30184000 - 0x30227fff WebKit? armv7 <73548a85ea2019f8dcc26fa76901baf7> /System/Library/PrivateFrameworks/WebKit?.framework/WebKit
0x303aa000 - 0x30492fff libGLProgrammability.dylib armv7 <2df3e678da66633548da62a54e2175f5> /System/Library/Frameworks?/OpenGLES.framework/libGLProgrammability.dylib
0x304e3000 - 0x30599fff Celestial armv7 <a0f4214f7959e75b98e492940645ecf1> /System/Library/PrivateFrameworks/Celestial?.framework/Celestial
0x305ab000 - 0x305adfff IOMobileFramebuffer armv7 <9f59b55a72f1d8d0e43447a683135abb> /System/Library/PrivateFrameworks?/IOMobileFramebuffer.framework/IOMobileFramebuffer
0x305ae000 - 0x30684fff CFNetwork armv7 <ab5bef5e6fdf6aa8cf3f004f7e39efd3> /System/Library/Frameworks?/CFNetwork.framework/CFNetwork
0x3084e000 - 0x3087bfff AppSupport? armv7 <6c1ff26aead596c7be8a3239bb3e49d9> /System/Library/PrivateFrameworks/AppSupport?.framework/AppSupport
0x308da000 - 0x30911fff IOKit armv7 <4bf3a02c4892ebe8223fb445ec4a4819> /System/Library/Frameworks?/IOKit.framework/Versions/A/IOKit
0x30912000 - 0x30e61fff WebCore? armv7 <c3ec24bdea0fe74728f0169fc96d5d1c> /System/Library/PrivateFrameworks/WebCore?.framework/WebCore
0x30f5f000 - 0x30f6afff libz.1.dylib armv7 <aaaf33ff0773fc3c877e3968102af6bf> /usr/lib/libz.1.dylib
0x3105b000 - 0x31099fff libvDSP.dylib armv7 <9fc2e924d3de29035e84b3101afa128c> /System/Library/Frameworks/Accelerate?.framework/Frameworks/vecLib.framework/libvDSP.dylib
0x310ab000 - 0x310effff libsqlite3.dylib armv7 <d27cddb6bf22470878e99474deb43153> /usr/lib/libsqlite3.dylib
0x310f0000 - 0x3111efff AddressBook? armv7 <0c21eae81e4d6ff3999de6f12371af64> /System/Library/Frameworks/AddressBook?.framework/AddressBook
0x3111f000 - 0x3112bfff GeoServices? armv7 <dbbad45a83fccba955fb137551f396a2> /System/Library/PrivateFrameworks/GeoServices?.framework/GeoServices
0x311ba000 - 0x312affff MusicLibrary? armv7 <4a8673c433548f3f48b28ed4fd138b4d> /System/Library/PrivateFrameworks/MusicLibrary?.framework/MusicLibrary
0x31465000 - 0x3146bfff liblockdown.dylib armv7 <b6126207dfdbee09c44e5211b59ed309> /usr/lib/liblockdown.dylib
0x316a1000 - 0x316a7fff IAP armv7 <745a1a2a265f0ee05379ff12a56d8d27> /System/Library/PrivateFrameworks?/IAP.framework/IAP
0x316be000 - 0x316cafff SpringBoardServices? armv7 <f4d34060b9e7d5db681e29456ec7ea06> /System/Library/PrivateFrameworks/SpringBoardServices?.framework/SpringBoardServices
0x316d5000 - 0x316ddfff MobileBluetooth? armv7 <02806a8557b022b1184f382c4ba7bff4> /System/Library/PrivateFrameworks/MobileBluetooth?.framework/MobileBluetooth
0x31761000 - 0x31762fff CoreSurface? armv7 <704d947935d3d5b0923cdf04e691a170> /System/Library/PrivateFrameworks/CoreSurface?.framework/CoreSurface
0x31763000 - 0x317adfff libstdc++.6.dylib armv7 <942e6611e195ec4df8a76cb3a87ebbee> /usr/lib/libstdc++.6.dylib
0x317ae000 - 0x318defff AudioToolbox? armv7 <5c7be7bc674eeb4196292c6c1fd55eff> /System/Library/Frameworks/AudioToolbox?.framework/AudioToolbox
0x31958000 - 0x3195dfff ProtocolBuffer? armv7 <7bf4ca82a8abc2b210bffa0ba996f892> /System/Library/PrivateFrameworks/ProtocolBuffer?.framework/ProtocolBuffer
0x3195e000 - 0x31a07fff libxml2.2.dylib armv7 <bf40ecb7167faf0b44814d264a4fb83d> /usr/lib/libxml2.2.dylib
0x31a3f000 - 0x31a42fff libGFXShared.dylib armv7 <b37757dc1bc1e448f25702dd088dfd3b> /System/Library/Frameworks?/OpenGLES.framework/libGFXShared.dylib
0x31af3000 - 0x31bc1fff CoreFoundation? armv7 <f6761ddb42f8362b10ade22cd2ff7640> /System/Library/Frameworks/CoreFoundation?.framework/CoreFoundation
0x31bc2000 - 0x31c03fff CoreTelephony? armv7 <98b449032252b4d7f09dde66be555f68> /System/Library/Frameworks/CoreTelephony?.framework/CoreTelephony
0x31c13000 - 0x31c44fff CoreLocation? armv7 <30603bdba9f47b9539697decbe57e7de> /System/Library/Frameworks/CoreLocation?.framework/CoreLocation
0x31c45000 - 0x31c47fff CrashReporterSupport? armv7 <570910e92ef090a52ea0cebe4df382dd> /System/Library/PrivateFrameworks/CrashReporterSupport?.framework/CrashReporterSupport
0x31c4a000 - 0x31d67fff Foundation armv7 <fa49834ea9f4fa38f609444659835fdb> /System/Library/Frameworks/Foundation?.framework/Foundation
0x31d88000 - 0x31d95fff libbsm.0.dylib armv7 <0b210420046cc351ed286294beaccf78> /usr/lib/libbsm.0.dylib
0x31d9e000 - 0x31da5fff libbz2.1.0.dylib armv7 <7f8e7214d843e557ee14ecbf69e7d8a9> /usr/lib/libbz2.1.0.dylib
0x31f17000 - 0x31fa2fff ImageIO armv7 <f0ad35f9cec543cca9590629d90bf140> /System/Library/Frameworks?/ImageIO.framework/ImageIO
0x31fa3000 - 0x31ff2fff CoreMedia? armv7 <cdc3442c91b9763a330fa0a7a7807144> /System/Library/Frameworks/CoreMedia?.framework/CoreMedia
0x32013000 - 0x320b8fff QuartzCore? armv7 <7dfb2226bcb468d0a6e4d0fed3ae6916> /System/Library/Frameworks/QuartzCore?.framework/QuartzCore
0x320c4000 - 0x320fcfff MobileCoreServices? armv7 <10784e735ac9b1d1435fd6ddeb9213fd> /System/Library/Frameworks/MobileCoreServices?.framework/MobileCoreServices
0x320fd000 - 0x32208fff libSystem.B.dylib armv7 <c3925e5675e7b233000c89b5b1f0edd3> /usr/lib/libSystem.B.dylib
0x3220b000 - 0x3220efff IOSurface armv7 <e07033d10145ebb62aae26b0974c569f> /System/Library/PrivateFrameworks?/IOSurface.framework/IOSurface
0x32257000 - 0x3225ffff libgcc_s.1.dylib armv7 <8f77516681034b309b0741a6ccd3310c> /usr/lib/libgcc_s.1.dylib
0x32260000 - 0x32260fff Accelerate armv7 <e9cb823ab5573a1b2b881d93d35f32f9> /System/Library/Frameworks/Accelerate?.framework/Accelerate
0x32261000 - 0x322fefff libobjc.A.dylib armv7 <d7ccd6e3e5d56804d3d0a3b7563a1c0a> /usr/lib/libobjc.A.dylib
0x322ff000 - 0x32314fff libresolv.9.dylib armv7 <593cc0a81b5ddeadd77242fc800be251> /usr/lib/libresolv.9.dylib
0x325ce000 - 0x3260dfff libGLImage.dylib armv7 <5dc557ef284a1cf9190813458784436c> /System/Library/Frameworks?/OpenGLES.framework/libGLImage.dylib
0x32644000 - 0x32762fff CoreGraphics? armv7 <6ec356366ace8b3dc60ff2c5ea93852b> /System/Library/Frameworks/CoreGraphics?.framework/CoreGraphics
0x32861000 - 0x328aafff GMM armv7 <88f346347151dccd7e10b22af722e971> /System/Library/PrivateFrameworks?/GMM.framework/GMM
0x329b2000 - 0x329d7fff Security armv7 <32c08b8495cdf8f566517bc872d1851d> /System/Library/Frameworks/Security?.framework/Security
0x329f9000 - 0x32a11fff libRIP.A.dylib armv7 <08c5bc154f24144ee3fc78128cc3c645> /System/Library/Frameworks/CoreGraphics?.framework/Resources/libRIP.A.dylib
0x32a31000 - 0x32a36fff MobileKeyBag? armv7 <ec741baaa065e00f502ba733c92fecd2> /System/Library/PrivateFrameworks/MobileKeyBag?.framework/MobileKeyBag
0x32a4d000 - 0x32abafff ProofReader? armv7 <e48ff814ec24df3e62c0a1c5da0843c9> /System/Library/PrivateFrameworks/ProofReader?.framework/ProofReader
0x32bdb000 - 0x32be6fff GraphicsServices? armv7 <22177d0a06ea163c543b4c2c05753815> /System/Library/PrivateFrameworks/GraphicsServices?.framework/GraphicsServices
0x32cb3000 - 0x32cb3fff vecLib armv7 <9b2fb7c7eaf32312deacd2a99c76583a> /System/Library/Frameworks/Accelerate?.framework/Frameworks/vecLib.framework/vecLib
0x32d40000 - 0x32d80fff CoreAudio? armv7 <968bbfa0aa05be0df286e4ff9e8b614b> /System/Library/Frameworks/CoreAudio?.framework/CoreAudio
0x32d81000 - 0x32e18fff MediaPlayer? armv7 <203164b1d5e2b1262cafe55764bfb264> /System/Library/Frameworks/MediaPlayer?.framework/MediaPlayer
0x32e7a000 - 0x32e7dfff ArtworkCache? armv7 <098bc39d180b9b9ed7720eea5fb5d35e> /System/Library/PrivateFrameworks/ArtworkCache?.framework/ArtworkCache
0x32e9d000 - 0x32ea3fff ITSync armv7 <277fc38eeab9c6d44b6d7049a3812958> /System/Library/PrivateFrameworks?/ITSync.framework/ITSync
0x331f0000 - 0x34137fff UIKit armv7 <d52d06d8c54da4627edafa88e3a9cfbe> /System/Library/Frameworks?/UIKit.framework/UIKit
0x34156000 - 0x341f5fff JavaScriptCore? armv7 <5493e191acc3ce8cb5d6202fb337a360> /System/Library/PrivateFrameworks/JavaScriptCore?.framework/JavaScriptCore
0x342d0000 - 0x342d9fff CoreVideo? armv7 <e1b7fbad588c28c975fa2061b08c1ddf> /System/Library/Frameworks/CoreVideo?.framework/CoreVideo
0x342da000 - 0x34308fff CoreText? armv7 <113143b562cf7680f4663dbbbbadbf2c> /System/Library/Frameworks/CoreText?.framework/CoreText
0x34309000 - 0x34337fff SystemConfiguration? armv7 <f976dd43c4ae57891cfc285ea4cb4e38> /System/Library/Frameworks/SystemConfiguration?.framework/SystemConfiguration
0x34393000 - 0x343dbfff libBLAS.dylib armv7 <342a46e96a3db679b2c945572c56c9d5> /System/Library/Frameworks/Accelerate?.framework/Frameworks/vecLib.framework/libBLAS.dylib
0x34583000 - 0x3481dfff libLAPACK.dylib armv7 <a4a5815d13764736fb51e8373e58c094> /System/Library/Frameworks/Accelerate?.framework/Frameworks/vecLib.framework/libLAPACK.dylib
0x3486a000 - 0x3486cfff MobileInstallation? armv7 <c920aa4e6b60f01878fd9b4b2c6e4c14> /System/Library/PrivateFrameworks/MobileInstallation?.framework/MobileInstallation
0x34876000 - 0x3498ffff libicucore.A.dylib armv7 <df7dde33384f016138404d5b5eb35906> /usr/lib/libicucore.A.dylib
0x34a45000 - 0x34a4dfff libkxld.dylib armv7 <6c9be2e1bdd184f9050f3a1743a5a74d> /usr/lib/system/libkxld.dylib
0x34a4e000 - 0x34a5bfff OpenGLES armv7 <72d855131708dafb8756ea7ce98f9918> /System/Library/Frameworks?/OpenGLES.framework/OpenGLES
0x34a5c000 - 0x34a8afff libCGFreetype.A.dylib armv7 <6062a082fda4145b053b15fc6f130af6> /System/Library/Frameworks/CoreGraphics?.framework/Resources/libCGFreetype.A.dylib
0x34a8b000 - 0x34aaafff Bom armv7 <e4b60db2a7ca456400cc9d6e56c6c72f> /System/Library/PrivateFrameworks/Bom?.framework/Bom
0x34c7e000 - 0x34c80fff libAccessibility.dylib armv7 <fa54ce11a99871cad8406f415e48e7c7> /usr/lib/libAccessibility.dylib
0x34c81000 - 0x34cb2fff VideoToolbox? armv7 <a4e683386a5605e759a9fc9d2b750bd6> /System/Library/PrivateFrameworks/VideoToolbox?.framework/VideoToolbox

Change History (2)

comment:1 Changed 10 years ago by zach

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #2057

comment:2 Changed 9 years ago by rob-to86

  • milestone Mobile Colloquy 1.2 deleted
Note: See TracTickets for help on using tickets.