Opened 13 years ago

Closed 9 years ago

#205 closed Defect (Works for Me)

Can't change nickname via connections window

Reported by: thraxisp.at.magma.ca Owned by: timothy
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Normal Keywords:
Cc:

Description

With 2D17, I can't change my nickname via the Connections window. It changes, then changes back.

To reproduce:
1) log in to two rooms
2) change your login name to something other than the default.

Response:
The name changes, then changes back in a few seconds. From the console, it looks like Colloquy changes it back. Console follows:

NICK thraxisp_t
thraxisp NICK
NICK thraxisp
thraxisp_t NICK

Change History (10)

comment:1 Changed 13 years ago by anonymous

Some more details. It works properly if you click on the highlighted line in the Connections window. It fails if you hit enter/return or click elsewhere in the connection window.

comment:2 Changed 13 years ago by anonymous

This is a GUI problem. Changing the nickname via the command line ( /nick new_name ) works.

comment:3 Changed 13 years ago by pv2b

  • Version changed from Latest Nightly to 2.0 (2D16)

I just independently discovered this same bug. I didn't even have to log on to two rooms.

comment:4 Changed 13 years ago by timothy

  • Resolution set to invalid
  • Status changed from new to closed

This is likely due to being in a room that prevents nick name changes.

comment:5 Changed 13 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

This happens in the colloquy room on irc.freenode.net...

comment:6 Changed 13 years ago by thraxisp.at.magma.ca

Here's the current console log (2D30).

When changing via the Connections window, and clicking elsewhere in the window, or hitting enter, the console looks like:

NICK thraxisp
thraxisp|away MODE thraxisp|away -e
thraxisp|away!n=thraxisp@… NICK
MODE +e
NICK thraxisp|away
thraxisp MODE thraxisp -e
thraxisp NICK
MODE +e

When I click on the same line, the following shows up in the log.

NICK thraxisp
thraxisp|away MODE thraxisp|away -e
thraxisp|away!n=thraxisp@… NICK
MODE +e

It looks like it may be that Colloquy is resetting the nickname in some cases.

comment:7 Changed 12 years ago by Rinoa <emily@…>

  • Resolution set to worksforme
  • Status changed from reopened to closed

This works for me. I agree with timothy, you are probably in a room that prevents nick changes..

comment:8 Changed 12 years ago by anonymous

I give up. I've trained myself to use the command line.

I did a tcpdump and your program changes it back without any prompting from the server. This is on irc.freenode.net. It works with other clients.

You either need to remove the function or paint a big target on where to click to make it work.

comment:9 follow-up: Changed 10 years ago by etherflan

  • priority changed from normal to high
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 2.0 (2D16) to Latest 2.1

Identify of original nick seems unsuccessful (despite the success message) and an underscore "_" is always appended

comment:10 in reply to: ↑ 9 Changed 9 years ago by jane

  • Resolution set to worksforme
  • Status changed from reopened to closed

Replying to etherflan:

Identify of original nick seems unsuccessful (despite the success message) and an underscore "_" is always appended

Sorry etherflan, I have no idea how your comment is relevant to this ticket. Please open a new ticket with your problem, or search for an existing one, thanks.

As to the original ticket, I can't reproduce. Please reopen if you continue to have problems.

Note: See TracTickets for help on using tickets.