Opened 10 years ago

Closed 10 years ago

#2035 closed Defect (Duplicate)

SILC Key Exchange Protocol error on a non standard port running Snow Leopard

Reported by: bman Owned by: timothy
Component: Colloquy (Mac) Version: 2.3 (Mac)
Severity: Blocker Keywords: SILC Key Exchange Protocol Snow Leopard
Cc:

Description

After upgrading to Snow Leopard, I installed Colloquy 2.3 and created new private and public keys. The new public key was put on the server. When trying to connect to the SILC server the Mac console gives a Key Exchange Protocol error.

[Warning] Error (type 1) during Key Exchange protocol
[Error] Error assembling packet

So it never returns the server key. We manually put the server key on the client machine but still same error when trying to connect.

We are running the server on a non-standard port and use pfs (Perfect Forward Security) and public key authentication.

The specific ciphers being used are:
aes-256-ctr with hmac-sha-256-96

We tried to run the connection both with SSL and with SSL turned off.

This was working with Mac Os X 10.5

Change History (1)

comment:1 Changed 10 years ago by zach

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #1854

Note: See TracTickets for help on using tickets.