Opened 5 years ago

Closed 5 years ago

#1933 closed Defect (Duplicate)

OperationalError: database is locked

Reported by: anonymous Owned by: timothy
Component: Colloquy (Mac) Version: 2.3 (Mac)
Severity: Normal Keywords:
Cc:

Description

How to Reproduce

While doing a GET operation on /project, Trac issued an internal error.

System Information

Trac 0.11.4
Python 2.4.3 (#3, Jun 8 2007, 04:52:06)
[GCC 3.4.6 20060404 (Red Hat 3.4.6-8)]
setuptools 0.6c5
SQLite 3.3.5
pysqlite 2.2.0
Genshi 0.5
Subversion 1.2.3 (r15833)

Python Traceback

Traceback (most recent call last):
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 435, in _dispatch_request
    dispatcher.dispatch(req)
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 230, in dispatch
    req.session.save()
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/web/session.py", line 124, in save
    (self.last_visit, self.sid, authenticated))
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/db/sqlite_backend.py", line 58, in execute
    args or [])
  File "/home2/javelin/webapps/colloquy_trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked


Change History (1)

comment:1 Changed 5 years ago by zach

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #1891

Add Comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.