Opened 10 years ago

Closed 10 years ago

#1833 closed Defect (Invalid)

Consistant crash when closing a window: WebKitThreadingException

Reported by: livings124 Owned by: timothy
Component: Colloquy (Mac) Version: 2.3 (Mac)
Severity: Major Keywords:
Cc:

Description

9/7/09 7:24:30 PM Colloquy[70386] An uncaught exception was raised
9/7/09 7:24:30 PM Colloquy[70386] void -[DOMNode dealloc](DOMNode*, objc_selector*) was called from a secondary thread
9/7/09 7:24:30 PM Colloquy[70386] * Terminating app due to uncaught exception 'WebKitThreadingException?', reason: 'void -[DOMNode dealloc](DOMNode*, objc_selector*) was called from a secondary thread'
* Call stack at first throw:
(

0 CoreFoundation? 0x00007fff803825a4 exceptionPreprocess + 180
1 libobjc.A.dylib 0x00007fff837c4313 objc_exception_throw + 45
2 CoreFoundation? 0x00007fff803823c7 +[NSException raise:format:arguments:] + 103
3 CoreFoundation? 0x00007fff80382354 +[NSException raise:format:] + 148
4 WebCore? 0x00007fff850a3d2e WebCoreReportThreadViolation? + 238
5 WebCore? 0x00007fff84a54d9a -[DOMNode dealloc] + 26
6 Colloquy 0x0000000100056cf1 -[JVStyleView dealloc] + 213
7 Foundation 0x00007fff82ef3494
NSFinalizeThreadData + 1204
8 libSystem.B.dylib 0x00007fff80c347e9 _pthread_tsd_cleanup + 187
9 libSystem.B.dylib 0x00007fff80c34434 _pthread_exit + 147
10 Foundation 0x00007fff82ef2fe0 NSFinalizeThreadData + 0
11 Foundation 0x00007fff82ef2f78
NSThreadmain + 1448
12 libSystem.B.dylib 0x00007fff80c3406e _pthread_start + 331
13 libSystem.B.dylib 0x00007fff80c33f21 thread_start + 13

)

Change History (1)

comment:1 Changed 10 years ago by zach

  • Resolution set to invalid
  • Status changed from new to closed

Can't reproduce.

Note: See TracTickets for help on using tickets.