Opened 13 years ago

Closed 12 years ago

#179 closed Defect (Works for Me)

Colloquy should display notices in the channel window

Reported by: anonymous Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Normal Keywords:
Cc: fs@…

Description

It seems as if NOTICEs are only displayed on the server console, but as they are sometimes used to communicate in the channel (e.g. OP notices), they should be displayed in the channel window (incoming and outgoing notices) and they should be marked accordingly (e.g. differentiate between general and OP notices).

Change History (6)

comment:1 Changed 13 years ago by timothy

  • Resolution set to wontfix
  • Status changed from new to closed

We only show notices in a channel that had the notice sent to it. If in fact the notice was sent to you we will not show it in the channel panel (this sounds like what is happening). You can enable notices to show up in notification bubbles in the Notification preferences.

Also we have a hidden preference (that will be public someday) that will allow notices to open panels.

http://www.colloquy.info/community/index.php?ShowNotices

comment:2 Changed 13 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Sorry, notices sent to users were not what I meant. Channel notices (/notice #channel foo) are indeed displayed in the channel window, but channel op notices (/notice @#channel foo) aren't. Notices or OP notices I send to a channel are not displayed, either. But all of them should.

comment:3 Changed 13 years ago by timothy

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in [2702]. Thanks for the clarification.

comment:4 Changed 13 years ago by timothy

We still need a way to distinguish between OP notices and general notices, but at least the messages aren't lost.

comment:5 Changed 13 years ago by Mike

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from enhancement to defect
  • Version changed from 2.0 (2D14) to 2.0 (2D16)

Notices sent to the whole channel do show in the channel, but there are still problems. OP Notices do not show in the channel. If I am an OP in a channel and an OP notice is sent, it instead pops up in a private message for me (though ONLY if a private message from the sender is already open. If no PM is open the message doesn't show anywhere). They don't even display on the console.

Also, regular and OP notices sent by me are still not displayed in the channel.

comment:6 Changed 12 years ago by akempgen

  • Resolution set to worksforme
  • Status changed from reopened to closed
  • Version changed from 2.0 (2D16) to Latest Nightly

That is because you are using a version that is older than the [2702] fix :) try updating to the latest beta, /notice #chatroom and /notice @#chatroom do work there and are all displayed in the proper panel (the chatroom).

If you still think there is a bug please feel free to reopen the ticket and provide a reproducible test case...

Note: See TracTickets for help on using tickets.