Opened 10 years ago

Last modified 10 years ago

#1781 reopened Defect

Nickserv doesn't always accept "IDENTIFY [preferredNickname] [password]"

Reported by: edilee@… Owned by: timothy
Component: Chat Core (IRC) Version: 2.3 (Mac)
Severity: Normal Keywords:
Cc:

Description

At least on irc.mozilla.org, IDENTIFY only takes a [password], so if you happen to rejoin on a bad network connection, Colloquy will do "IDENTIFY [preferredNickname] [password]" and fail even if you already linked the alt nickname to the main account because Nickserv will take [preferredNickname] as the password.

This regression initially landed with:
http://colloquy.info/project/changeset/4164

and I believe last touched here:
http://colloquy.info/project/changeset/4177

Change History (2)

comment:1 Changed 10 years ago by zach

  • Resolution set to fixed
  • Status changed from new to closed

akempgen fixed this in [4622].

comment:2 Changed 10 years ago by akempgen

  • Component changed from Colloquy (Mac) to Chat Core (IRC)
  • Resolution fixed deleted
  • Status changed from closed to reopened

actually that fix doesnt work on irc.mozilla.org, it responds differently to the "faulty" /nickserv identify <nick> <pass> command than for example irc.foonetic.net

Note: See TracTickets for help on using tickets.