Opened 11 years ago

Closed 10 years ago

Last modified 4 years ago

#1776 closed Defect (Fixed)

Colloquy doesn't use Growl even if installed and running.

Reported by: twen Owned by: timothy
Component: Colloquy (Mac) Version: 2.3 (Mac)
Severity: Normal Keywords: growl, notification
Cc: dkh@…

Description

It seems that colloquy 2.3 doesn't recognise on my macbook (10.5.8) that growl 1.1.4 and 1.1.6 is running. So colloquy does use it own built in notification instead of growl.

I stopped colloquy 2.3, updated this morning from growl 1.1.4 to 1.1.6. Starting Colloquy 2.3 again, it seemed to find growl and send notifications through. But after several hours of use, a shutdown / restart of the machine, Colloquy 2.3 didn't find Growl again.

BTW : this behavior didn't occur with growl 1.1.4 + colloquy 2.2.2.

Change History (11)

comment:1 Changed 11 years ago by ScottM

I have arrived in your time period with the help of my TARDIS. In the future, Friday, to be precise, I'll claim that this problem is indeed present and confirmable on operating systems available at that time. Notifications work only on the same Space (if spaces are used) as colloquy and when Colloquy is not the active application. The problem seemed to become an issue when our futuretastic operating systems doubled the number of bits used natively in the application, whereas Growl did not.

See you in the future!

comment:2 Changed 11 years ago by donut

  • Cc dkh@… added

I'm having the same issue but on 10.6 (10A432) but the last comment kinda explains this although the OP did say 10.5.8 which is out...

comment:3 Changed 11 years ago by ScottM

Confirmed for the bit issue - I set Colloquy to 32bit mode and Growl is working again. Not sure whose problem that really is to fix though..

comment:4 Changed 11 years ago by bogo_lode

from what I can tell, colloquy was built without a 64 bit growl.framework in the app. back to adium for me.

comment:5 Changed 11 years ago by zach

We won't be updating Growl.framework with the 64bit version until the folks at Growl release a stable (non-beta) version that can be used.

comment:6 Changed 11 years ago by dangerfan

Just FYI - I downloaded the Growl beta 1.2b1, built it, and used that to build Colloquy from source. I still couldn't get it to work. Anyone else try this with success? I know the Growl update is still in beta, but it seems to be working for most other apps. I built both Growl and Colloquy as 64 bit apps.

comment:7 follow-up: Changed 11 years ago by zach

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [4628].

comment:8 in reply to: ↑ 7 Changed 10 years ago by binford2k

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to NoOneButMe:

Fixed in [4628].

Growl 1.2 has been out for a while. Can we have a release supporting it? Build #4630 works fine

comment:9 Changed 10 years ago by zach

  • Resolution set to fixed
  • Status changed from reopened to closed

This is still fixed. And there are some other issues that need to be fixed before another build is released.

comment:10 Changed 6 years ago by zach

As of 10.8, Colloquy will use Notification Center instead of built-in bubbles or Growl. Growl support only remains for 10.7 support.

Note: See TracTickets for help on using tickets.