Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#1766 closed Defect (Fixed)

Server password is not saved

Reported by: ijsf Owned by: kiji.roshi
Component: Colloquy (iOS) Version: Local Build
Severity: Normal Keywords: password server save store
Cc:

Description

The server authentication password that can be configured through the Advanced tab is not saved and is subsequently lost after restart the Colloquy application.

To reproduce, connect to an IRC server by using a server authentication password. Restarting the application will result in failure to connect.

Affected revision: 4620.

(There are more issues involving server authentication passwords, e.g. #1731)

Change History (3)

comment:1 Changed 9 years ago by kiji.roshi

  • Resolution set to fixed
  • Status changed from new to closed

Might be fixed by [4670]. Otherwise can't reproduce.

comment:2 Changed 8 years ago by gboudreau

I can reproduce all the time with a self-compiled app from r4865.
Anything I could provide that would help identify the problem?
(Note: I have a jailbroken device, so I can access the iPad filesystem to look for files etc. if that could help.)

comment:3 Changed 8 years ago by gboudreau

Zach (NoOneButMe?) talked to me about this in the IRC channel.
He's pretty sure my problem is jailbreak-related.
And it would make sense, since the password would be saved in the keychain, and I see some errors in the console that look like this:
<Error>: Colloquy[2939] SecItemDelete?: missing entitlement
also SecItemUpdate? and SecItemAdd?
I can't reproduce the problem in the iPad Simulator.
So case closed.

Note: See TracTickets for help on using tickets.