Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#1680 closed Defect (Won't Fix)

No confirmation on quit

Reported by: anonymous Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Normal Keywords:
Cc:

Description

Would be nice if Colloquy didn't request any confirmation on quit.

I've checked most of my applications, and no other app asks for confirmation on quit. Eg. Skype, Mail, iChat are some examples of other communication clients that don't ask.

Change History (4)

comment:1 Changed 11 years ago by akempgen

  • Resolution set to wontfix
  • Status changed from new to closed

this is intended. other apps ask if there are unsaved changes, we ask if there are open connections.

to quit without prompt use cmd-option-q

comment:2 Changed 10 years ago by jackr

Disagree with the analogy to "unsaved changes." UI guidelines say to ask-before-quit if something would thereby be irrecoverably lost. Connections are not irrecoverably lost; they'll be made again at startup.

Anyway: one may work around this in the "Keyboard & Mouse" System Preferences panel, Keyboard Shortcuts tab, by defining Application Keyboard Shortcuts for Colloquy:

  • Quit Colloquy: ⌘Q
  • Quit Colloquy…: ⌥⌘Q

Remember that "…" is "opt-;", not three dots

comment:3 Changed 10 years ago by zach

Dupe of #261.

comment:4 Changed 10 years ago by Billy

I have to +1 this one. An open connection is in no way, shape, or form an 'unsaved change'. Not one other client program I have on my computer right now (FTP, MySQL, Twitter, iChat, mail) considers an open connection to be an 'unsaved change' that it prompts you about before quitting. The quit message is just completely frustrating.

Note: See TracTickets for help on using tickets.