Opened 6 years ago

Last modified 6 years ago

#1551 new Defect

[incompatible encoding] on blank lines

Reported by: daniel@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Normal Keywords: [incompatible encoding]
Cc:

Description

It appears when receiving blank messages, Colloquy displays the text [incompatible encoding]. I have changed the encoding for both the channel and the server from UTF-8 to Latin-1 with no change in the issue.

I took two screenshots of the issue. Colloquy is on the left of both images, with another IRC client on the right.

http://everythingdaniel.com/uploads/compare.png
http://everythingdaniel.com/uploads/compare2.png

In the first picture, it appears that Colloquy took two blank lines and only put out one [incompatible encoding] message.

I have only seen this on a automated help channel that echos out a .txt file, this only appears to be connected to blank messages coming through.

Change History (1)

comment:1 Changed 6 years ago by everythingdaniel

Some additional info....

I now know this error does not occur with white space characters. I took the transcript that causes the error and tried to reproduce the error with no luck. I also tried to copy in some of the "Whitespace" programing language with no error.

It still must be blank messages.

Add Comment

Modify Ticket

Action
as new
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.