Opened 13 years ago

Closed 11 years ago

Last modified 10 years ago

#155 closed Defect (Works for Me)

First received PM does not show

Reported by: yurivish@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Major Keywords: first private message direct chat
Cc: jauguste@…

Description

When someone PM's me, I get the PM window open, but with no message. If they PM me again, I get their second message, and am able to talk to them with no further problems.

Change History (19)

comment:1 Changed 13 years ago by timothy

Can this be tested and verified on the new nightly? I think it might be fixed now, but I want to make sure.

comment:2 Changed 13 years ago by timothy

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed in [2589]. Someone please verify (it stopped happening for me.)

comment:3 Changed 13 years ago by timothy

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 12 years ago by anonymous

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:5 Changed 12 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 2.0 (2D9) to Latest Nightly

i still have this issue with the 2D41 release

comment:6 Changed 12 years ago by mcglynn

This is still a problem with Version 2.1 (3263). It does not seem to be dependent on the UI style; I've reproduced the bug with the "tabbed windows" option as well as the default drawer style.

To be clear, the bug seems to be: when I first /msg someone, colloquy will open a new tab for the private chat, but will not send the actual /msg text. The recipient is notified that he has receive a private message, but there is no message content. In my private chat window, the /msg text I created does not appear.

comment:7 Changed 12 years ago by jauguste@…

the issue happend also when the pv sender runs another client than colloquy

comment:8 Changed 12 years ago by amoebus@…

This is still a bug with the latest update that Colloquy had me download (2.1 (3275)), as described by mcglynn. When I recieve a /msg from any other user, I am notified that <username> has sent me a private message and a PM window opens. On opening the window, there is no text.

comment:9 Changed 12 years ago by andysquirrel

this has been happening to me since the last 3 nightly builds

comment:10 Changed 12 years ago by timothy

This should be better in 3275, but it seems there is still an issue...

comment:11 Changed 12 years ago by timothy

There was a build issue with the 3275 release, 3275.1 fixes that.

comment:12 Changed 12 years ago by timothy

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:13 Changed 12 years ago by jauguste@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

i still have the issue with the 3275.1 :/ i am an isolated case ? :)

comment:14 Changed 11 years ago by akempgen

  • Cc jauguste@… added
  • Keywords first private message direct chat added; PM removed

still an issue?

comment:15 Changed 11 years ago by mcglynn

I can reproduce this issue, as described by me on 06/07/06 in this bug, with version 2.1/3321.

As noted previously, when I type '/msg foo bar' (and press the return key) colloquy will open a new tab or window for this private chat, but the message 'bar' will not appear in the new tab/window. When I switch back to the original tab or window, my command '/msg foo bar' still appears there, as if I did not press the return key. If I press the return key at that point, the message *will* be sent.

The bug appears to be that Colloquy can't send a private chat message if it also has to open a new pane/tab/window. Once the pane/tab/window is open, messaging works fine.

comment:16 Changed 11 years ago by akempgen

  • Resolution set to worksforme
  • Status changed from reopened to closed

if you still have this bug, please visit the colloquy chat room so we can test it. at the moment, nobody can reproduce this...

comment:17 Changed 10 years ago by evan

This problem is happening again on 2.1 (3590). I'll try the nightly or something before I reopen the ticket.

comment:18 Changed 10 years ago by evan

Can't find a nightly build that seems up to date. Where should I look?

comment:19 Changed 10 years ago by Rinoa

There is no nightly anymore. You can only build from source.

Note: See TracTickets for help on using tickets.