Opened 11 years ago

Closed 11 years ago

#1519 closed Defect (Fixed)

Mobile colloquy mashes two networks together

Reported by: joe@… Owned by: kiji.roshi
Component: Colloquy (iOS) Version: 1.0 (iOS)
Severity: Normal Keywords:
Cc: joe@…

Description

I have two networks set up in Mobile Colloquy, but they seem to get "mashed together" or exchanged upon quit and reload. Channels from one connection get put into another, and one connection seems to be confused with the other.

The important part of this is that my connections are both on the same server, on the same port, but with a different password (I use multiple connections to the bip irc proxy to manage my multiple connections) and a different name ("mozilla", "personal"). I suspect that the fact that the server name, port, ssl state (on) are all the same are confusing colloquy.

Change History (5)

comment:1 Changed 11 years ago by jane

  • Resolution set to worksforme
  • Status changed from new to closed

Sorry, I can't reproduce, even under similar circumstances (i.e. I use znc with multiple connections to same server, ssl, same port, different names and paswords).

Unfortunately it'll be impossible to get a copy of your .plist Colloquy uses to remember connections, but from what I can see that problem shouldn't be happening...all I can suggest is deleting Colloquy, redownloading (it is free from the app store) and reinstalling and setting up your connections again.

comment:2 Changed 11 years ago by jane

  • Resolution worksforme deleted
  • Status changed from closed to reopened

patch from maurits dijkstra attached (and to be discussed) and ticket reopened, seems this is a bip specific issue.

comment:3 follow-up: Changed 11 years ago by joe@…

  • Cc joe@… added

Should I fire up a build of Mobile Colloquy with this patch to let you know if it fixes my problem with bip?

comment:4 in reply to: ↑ 3 Changed 11 years ago by jane

Replying to joe@drew.ca:

Should I fire up a build of Mobile Colloquy with this patch to let you know if it fixes my problem with bip?

It's pretty much verified that the patch does fix the bip problem, but it has some side effects that would require all users to re-enter some of their connection info regardless, which is not ideal.

comment:5 Changed 11 years ago by kiji.roshi

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r4448.

Note: See TracTickets for help on using tickets.