Opened 11 years ago

Last modified 10 years ago

#1418 reopened Defect

Colloquy crashes when closing last channel

Reported by: willem-jan Owned by: timothy
Component: Colloquy (Mac) Version: Local Build
Severity: Normal Keywords: crash, last, channel
Cc:

Description

Sometimes I close the last channel (that is the last of all the servers), but don't quit Colloquy. I hit Cmd+W and the channel should just close.
But, even if there is still a console tab open, Colloquy crashes when I do that. It just stops responding and crashes after a few seconds. I wouldn't find it that big of a problem, but is is very annoying when you accidently close that tab (wanted te close a browser window, but forgot Colloquy still had focus), because you can't rejoin the channel very fast because you need to restart Colloquy.

Change History (4)

comment:1 Changed 11 years ago by jane

  • Resolution set to worksforme
  • Status changed from new to closed

Unless you have steps to reproduce, or can narrow it down (i.e. it only happens with a certain room on a certain server with a certain style), I can't reproduce.

comment:2 Changed 11 years ago by willem-jan

Can't find anything that makes a difference. Tries different servers, different style, different channels, different encoding.
I will attach the crash report, maybe that can help.

comment:3 Changed 10 years ago by loudambiance

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 2.2 (Mac) to Built Source

Steps to replicate:
Join a new channel /join #somerandomchannel
Once joined, cmd+w that channel.

Crashes for me every time.

comment:4 Changed 10 years ago by loudambiance

Appears to be caused by active javascript plugins (I tested with SimpleSlap? and the Bash.org Quote script i wrote) Each of them can cause it to crash without the other installed.

Note: See TracTickets for help on using tickets.