Opened 10 years ago

Closed 6 years ago

#1401 closed Defect (Duplicate)

Query windows cannot send commands to znc

Reported by: narge Owned by: timothy
Component: Colloquy (Mac) Version: 2.2 (Mac)
Severity: Normal Keywords:
Cc: narge-colloquy-bugs@…, mmitar@…

Description

The znc bouncer is controlled by sending messages to pseudo-users with nicks starting with *. For example, connections and the general state of the bouncer is controlled by privmsg to *status, and the auto-away plugin is controlled by sending messages to *away. However, znc passes watch commands directly to the real server, so colloquy will be told that these users are offline:

WATCH +*status
605: *status * * 0 is offline

As of colloquy 2.2, this makes it impossible to simply type a command in the *status query window; colloquy will display an error dialog. Instead, one must type /msg *status command.

This is arguably a bug in znc, but Colloquy's preemptive denial of messages typed in query windows is still annoying. Why are they not handled the same way as /msg commands? (ie, sent to the server, and then the error dialog shown if the server responds with a 401)

Change History (6)

comment:1 Changed 10 years ago by narge

  • Cc narge-colloquy-bugs@… added

comment:2 Changed 10 years ago by timothy

  • Status changed from new to assigned

Thanks for the ticket. This is related to #1346.

comment:3 Changed 10 years ago by zach

Related: #1414

comment:4 Changed 10 years ago by zach

  • Resolution set to wontfix
  • Status changed from assigned to closed

*status isn't actually a user, so its not online. http://en.znc.in/wiki/Fakeonline will fake the online status for *status. Colloquy can't really fix this, since *status can actually be *anything, defined by the user in ZNC's config.

comment:5 Changed 9 years ago by mitar

  • Cc mmitar@… added
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Could at least this user-online-check "feature" be made configurable? Or at least it could still allow you to send a message, just it would warn you that user is probably offline and will not get a message. Like Adium does. It does not need to be configurable on per-nick basis. I would completely turn off this feature for me.

comment:6 Changed 6 years ago by zach

  • Resolution set to Duplicate
  • Status changed from reopened to closed

Closing this as a dupe of #1346.

Note: See TracTickets for help on using tickets.