Opened 9 years ago

Closed 9 years ago

#1398 closed Enhancement (Fixed)

Automatic commands should be executed after Identify

Reported by: flomutter Owned by: akempgen
Component: Chat Core (IRC) Version: 2.2 (Mac)
Severity: Normal Keywords:
Cc:

Description

Automatic commands should be executed after identify because sometimes you need auto commands after you are identified (op and stuff)

Change History (6)

comment:1 Changed 9 years ago by akempgen

  • milestone set to Colloquy 2.3
  • Resolution set to duplicate
  • Status changed from new to closed

same as #1380, keeping the older one cause it has more.. "info".. in it.

comment:2 Changed 9 years ago by akempgen

actually a dupe of #1217, your problem might also be already fixed by [4178].

comment:3 Changed 9 years ago by akempgen

  • Component changed from Colloquy (Mac) to Chat Core (IRC)
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Type changed from Defect to Enhancement

not a dupe of anything, i fail

comment:4 Changed 9 years ago by akempgen

  • Owner changed from timothy to akempgen
  • Status changed from reopened to new

comment:5 Changed 9 years ago by akempgen

  • Status changed from new to accepted

comment:6 Changed 9 years ago by akempgen

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in [4242], auto commands that are prefixed with \ instead of / are executed after successful identification: \cs invite #inviteOnlyRoom. (auto commands prefixed with / and raw auto commands are run as soon as possible like they always were)

Note: See TracTickets for help on using tickets.