Opened 10 years ago

Closed 10 years ago

#1380 closed Defect (Fixed)

Automatic commands should be executed after Identify

Reported by: bourne Owned by: akempgen
Component: Chat Core (IRC) Version: 2.2 (Mac)
Severity: Normal Keywords: invite join identify
Cc:

Description

I have problems joining "invite only" channels on startup. It did work under version 2.1 - no changes done in my connection settings.

Settings:
under Connections.Info.General: nickname/pw set
under Connections.Automatic: connect on launch
under Connections.Automatic.Command:
/nick nickname
/ns IDENTIFY ....
/cs invite #...
/j #...

It seems that the cs invite is sent before the nick is identified. I appologize if this is an already submitted bug, I did search (and not find one) and really wonder that no one submitted before...

Change History (12)

comment:1 Changed 10 years ago by timothy

Can you paste the output you see in /console here. Open the console then disconnect and reconnect. The paste the output here, stripping your passwords, etc.

Do you have the room in the auto join list? Maybe try removing it and just use the commands you have.

comment:2 follow-up: Changed 10 years ago by bourne

NICK bourne
USER bourne 0 * bourne
ns IDENTIFY
cs invite #[liga]member

NOTICE bourne * If you are having problems connecting due to ping timeouts, please type /notice EEC79762 nospoof now.
PING EEC79762
PONG EEC79762
451: * You have not registered
451: * You have not registered
001: Welcome to the euIRCnet IRC Network bourne
002: Your host is irc.inn.at.euirc.net, running version euIRCd1.1.6rc2
003: This server was created Mon Aug 07 2006 at 22:04:40 CEST
004: irc.inn.at.euirc.net euIRCd1.1.6rc2 oOiRwhsSaHANCrxjWqBZ1dtcpPUn vhoaqpsmtinrRQKVHOAYCNcSXUWbeIwklfLBuFM
005: NETWORK=euIRCnet WATCH=128 SAFELIST PREFIX=(qaohv)*!@%+ CHANMODES=bewI,k,flBL,cimnprstACHKNOQRSVWXY CHANTYPES=#&+ KICKLEN=307 KNOCK MAP MAXBANS=100 MODES=6 NICKLEN=30 SILENCE=5 TOPICLEN=307 WALLCHOPS MAXCHANNELS=20 MAXTARGETS=20 are available on this server
251: There are 43 users and 6179 invisible on 10 servers
252: 33 operator(s) online
253: 3 unknown connection(s)
254: 3352 channels formed
255: I have 1373 clients and 1 servers
265: Current Local Users: 1373 Max: 2121
266: Current Global Users: 6222 Max: 10123
375: - irc.inn.at.euirc.net Message of the Day -
372: - 31/12/2008 7:41
372: - Willkommen im euIRC (European IRC Network).
372: -
372: - Innsbruck / Austria (irc.inn.at.euirc.net) (nemox.net)
372: -
372: - Regeln:
372: -
372: - Mit dem Verbindungsaufbau zu diesem Server werden
372: - folgende Benutzungsregeln verbindlich
372: - akzeptiert:
372: -
372: - - Keine Massnahmen, die unnoetigen Netzverkehr
372: - verursachen.
372: - - Keine Massenwerbung fuer Webseiten, Channels,
372: - Produkte oder Sonstiges.
372: - - Desweiteren gelten die allgemeinen Regeln fuer
372: - die Benutzung dieses Mediums, die auf
372: - http://www.euirc.net/
372: - nachlesbar sind.
372: - - Von den Betreibern wird keinerlei Verantwortung bzgl.
372: - Verfuegbarkeit und Inhalte des IRC-Dienstes uebernommen.
372: - Fuer die Inhalte sind die Benutzer selbst verantwortlich.
372: -
372: - Die Benutzung des IRC ist kein Recht, nichts
372: - das man in irgendeiner Form verlangen, erklagen,
372: - oder anderweitig erzwingen kann. IRC ist ein Privileg.
372: - Die Administratoren behalten sich das Recht vor,
372: - jederzeit, ohne Angabe von Gruenden, einem Einzelnen
372: - oder einer Gruppe von Benutzern das Privileg der Nutzung
372: - dieses IRC-Servers temporaer oder permanent zu
372: - entziehen. In Einzelfaellen kann diese Massnahme durch
372: - eine Sperrung auf allen internationalen Servern
372: - vollzogen werden.
372: -
372: - AUP (Acceptable Usage Policy):
372: -
372: - http://www.euirc.net/de/aup.php
372: -
372: - Kontaktpersonen:
372: -
372: - Serveradministrator: RES <res-1@…>
372: - Servicesadministrator: Armin <armin@…>
372: - Lokaler Operator: Medice <medice@…>
376: End of /MOTD command.
bourne MODE +ix
Global NOTICE [Logon News - Jun 08 2006] In using this service you agree the terms at http://www.euirc.net/en/aup.php - notice that every connection attempt will be scanned, info: http://scanner.euirc.net/
Global NOTICE [Logon News - Dec 09 2007] Get your @euirc.eu Mailaddress for FREE at http://www.euirc.net/en/euircmail.php
Global NOTICE [Logon News - Dec 18 2007] IPv6 connections available on euirc! Use the server irc.euirc.net and join #ipv6
NickServ? NOTICE This nickname is registered and protected. If it is your
NickServ? NOTICE nick, type /msg NickServ? IDENTIFY password. Otherwise,
NickServ? NOTICE please choose a different nick.
NickServ? NOTICE If you do not change within one minute, I will change your nick.
SpamScanner? CTCP REQUEST VERSION
SpamScanner? CTCP REQUEST LAG
SpamScanner? CTCP REQUEST TIME
NickServ? IDENTIFY
*
NickServ? NOTICE Password accepted - you are now recognized.
JOIN #[liga]member
473: #[liga]member Cannot join channel (+i)

JOIN #RXTeam,#RXTeam-external,#revorix,#[LIGA]
JOIN #rxteam

The error message popup tells me, that the channel is invite only....

comment:3 Changed 10 years ago by bourne

And no, the room is not in the Auto-Join list, but others are.

comment:4 in reply to: ↑ 2 Changed 10 years ago by akempgen

NICK bourne
USER bourne 0 * bourne
ns IDENTIFY **********
'''cs invite #[liga]member'''

NOTICE bourne *** If you are having problems connecting due to ping timeouts, please type /notice EEC79762 nospoof now.
PING EEC79762
PONG EEC79762
451: * You have not registered
451: * You have not registered
001: Welcome to the euIRCnet IRC Network bourne
002: Your host is irc.inn.at.euirc.net, running version euIRCd1.1.6rc2
003: This server was created Mon Aug 07 2006 at 22:04:40 CEST
004: irc.inn.at.euirc.net euIRCd1.1.6rc2 oOiRwhsSaHANCrxjWqBZ1dtcpPUn vhoaqpsmtinrRQKVHOAYCNcSXUWbeIwklfLBuFM
005: NETWORK=euIRCnet WATCH=128 SAFELIST PREFIX=(qaohv)*!@%+ CHANMODES=bewI,k,flBL,cimnprstACHKNOQRSVWXY CHANTYPES=#&+ KICKLEN=307 KNOCK MAP MAXBANS=100 MODES=6 NICKLEN=30 SILENCE=5 TOPICLEN=307 WALLCHOPS MAXCHANNELS=20 MAXTARGETS=20 are available on this server
251: There are 43 users and 6179 invisible on 10 servers
252: 33 operator(s) online
253: 3 unknown connection(s)
254: 3352 channels formed
255: I have 1373 clients and 1 servers
265: Current Local Users: 1373  Max: 2121
266: Current Global Users: 6222  Max: 10123
375: - irc.inn.at.euirc.net Message of the Day - 
372: - 31/12/2008 7:41
372: - Willkommen im euIRC (European IRC Network).
372: - 
372: - Innsbruck / Austria (irc.inn.at.euirc.net) (nemox.net)
372: - 
372: - Regeln:
372: - 
372: - Mit dem Verbindungsaufbau zu diesem Server werden 
372: - folgende Benutzungsregeln verbindlich
372: - akzeptiert:
372: - 
372: - - Keine Massnahmen, die unnoetigen Netzverkehr
372: -   verursachen.
372: - - Keine Massenwerbung fuer Webseiten, Channels,
372: -   Produkte oder Sonstiges.
372: - - Desweiteren gelten die allgemeinen Regeln fuer
372: -   die Benutzung dieses Mediums, die auf 
372: -        http://www.euirc.net/ 
372: -   nachlesbar sind.
372: - - Von den Betreibern wird keinerlei Verantwortung bzgl.
372: -   Verfuegbarkeit und Inhalte des IRC-Dienstes uebernommen.
372: -   Fuer die Inhalte sind die Benutzer selbst verantwortlich.
372: - 
372: - Die Benutzung des IRC ist kein Recht, nichts
372: - das man in irgendeiner Form verlangen, erklagen,
372: - oder anderweitig erzwingen kann. IRC ist ein Privileg.
372: - Die Administratoren behalten sich das Recht vor,
372: - jederzeit, ohne Angabe von Gruenden, einem Einzelnen
372: - oder einer Gruppe von Benutzern das Privileg der Nutzung
372: - dieses IRC-Servers temporaer oder permanent zu
372: - entziehen. In Einzelfaellen kann diese Massnahme durch
372: - eine Sperrung auf allen internationalen Servern
372: - vollzogen werden.
372: - 
372: - AUP (Acceptable Usage Policy):
372: - 
372: -      http://www.euirc.net/de/aup.php
372: - 
372: - Kontaktpersonen:
372: - 
372: - Serveradministrator:   RES <res-1@communicate.at>
372: - Servicesadministrator: Armin <armin@euirc.net>
372: - Lokaler Operator:      Medice <medice@euirc.net>
376: End of /MOTD command.
bourne MODE +ix
Global NOTICE [Logon News - Jun 08 2006] In using this service you agree the terms at http://www.euirc.net/en/aup.php - notice that every connection attempt will be scanned, info: http://scanner.euirc.net/
Global NOTICE [Logon News - Dec 09 2007] Get your @euirc.eu Mailaddress for FREE at http://www.euirc.net/en/euircmail.php
Global NOTICE [Logon News - Dec 18 2007] IPv6 connections available on euirc! Use the server irc.euirc.net and join #ipv6
NickServ NOTICE This nickname is registered and protected.  If it is your
NickServ NOTICE nick, type /msg NickServ IDENTIFY password.  Otherwise,
NickServ NOTICE please choose a different nick.
NickServ NOTICE If you do not change within one minute, I will change your nick.
SpamScanner CTCP REQUEST VERSION
SpamScanner CTCP REQUEST LAG
SpamScanner CTCP REQUEST TIME
'''NickServ IDENTIFY ***********
NickServ NOTICE Password accepted - you are now recognized.
JOIN #[liga]member
473: #[liga]member Cannot join channel (+i)'''
JOIN #RXTeam,#RXTeam-external,#revorix,#[LIGA]
JOIN #rxteam

comment:5 Changed 10 years ago by akempgen

could be the same as #1350

comment:6 follow-up: Changed 10 years ago by bourne

No it is not the same as #1350. I don't care about an alert, the problem is sending the cs invite to a closed audience channel before the nick is identified and therefore nickserv does not send the invite and consequently the join fails. As I have several channels like this, this is a rather annoying bug, I have to manually enter all the cs invites after startup...

comment:7 in reply to: ↑ 6 Changed 10 years ago by akempgen

Replying to bourne:

No it is not the same as #1350. I don't care about an alert, the problem is sending the cs invite to a closed audience channel before the nick is identified and therefore nickserv does not send the invite and consequently the join fails. As I have several channels like this, this is a rather annoying bug, I have to manually enter all the cs invites after startup...

have you tried putting your nickserv information in the connection > get info inspector instead of using /ns identify? where it says nickname & password.

comment:8 Changed 10 years ago by bourne

Sure. Put it there, put it in commands, put it in both. None works.

comment:9 Changed 10 years ago by akempgen

  • milestone set to Colloquy 2.3

[4164] might improve things if using the nickname/password settings.

comment:10 Changed 10 years ago by akempgen

related to #1217

comment:11 Changed 10 years ago by akempgen

  • Owner changed from timothy to akempgen
  • Status changed from new to assigned
  • Summary changed from Joining "invite-only" channels on Startup to Automatic commands should be executed after Identify
  • Type changed from Defect to Enhancement

comment:12 Changed 10 years ago by akempgen

  • Component changed from Colloquy (Mac) to Chat Core (IRC)
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Type changed from Enhancement to Defect

actually this really was a bug, fixed in [4178].

Note: See TracTickets for help on using tickets.