Opened 11 years ago

Closed 10 years ago

#1312 closed Enhancement (Duplicate)

Have Colloquy's search work like Safari's

Reported by: Robby Owned by: timothy
Component: Colloquy (Mac) Version: Local Build
Severity: Normal Keywords:
Cc: ttom@…

Description

Using r3935 I find the current search function slightly clumsy whereas Safari's implementation is very elegant.

1. Highlights

While they do let you manage to find your search result, the "ticks", lines on the scrollbar in Colloquy aren't as clear and obvious as a highlighted word.

2. Search bar

As you will know, Safari has an in-main-window search "bar" instead of a dedicated window. This saves screen real estate and is visually more appealing.
I wouldn't mind have this search bar at the bottom of the window like Camino has it, this might even suit Colloquy better.
I do not know if it were possible to fit all the detailed options that the Colloquy search windows features into such a bar but I'd reckon that they are hardly ever used by the common user.

In all, I think implementating a Safari-type search would really bring the attractiveness of the search in line with Colloquy overall appeal.

Change History (4)

comment:1 Changed 11 years ago by timothy

  • Status changed from new to assigned

I agree!

comment:2 Changed 11 years ago by timothy

  • Cc ttom@… added

comment:3 Changed 11 years ago by zach

  • milestone set to Colloquy 3.0

comment:4 Changed 10 years ago by zach

  • milestone Colloquy 3.0 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Dupe of #759

Note: See TracTickets for help on using tickets.