Opened 14 years ago

Closed 13 years ago

#130 closed Defect (Duplicate)

Colloquy freezes temporarily with too much activity, e.g. netsplit, or pasting > 4 lines at the same time

Reported by: caseygollan@… Owned by: timothy
Component: Colloquy (Mac) Version: Local Build
Severity: Major Keywords:
Cc:

Description

read the short summary not to much else

Change History (7)

comment:1 Changed 14 years ago by eridius

Since none of us have seen this, you need to sample Colloquy during the freeze and attach it, otherwise we won't be able to fix it.

comment:2 Changed 14 years ago by timothy

The pasting 4 or more lines part was fixed in [2579] (also this part was a duplicate of #102).

comment:3 Changed 14 years ago by anonymous

I just downloaded the latest Colloquy and experienced this error. Try joining a channel with thousands of people and lots of message churn, like, say, #BT on EFnet and you should see it too ...

comment:4 Changed 14 years ago by Benjamin Podszun

I just experienced this problem with 2D16 on a (imo) low traffic channel:

Chatting in freenode/##java I experienced a netsplit that removed ~180 (nearly all) users from the channel. My colloquy CPU usage was very high (60-90%) and it didn't respond for about 20-30s. Exactly the same happened, after the net split was over and all others joined again.
Worst about this problem: It renders the machine (powerbook G4, 1,5 GB ram) very slow/near to unusable during that time.

comment:5 Changed 14 years ago by anonymous

I keep having this happen too. Very annoying; considering switching clients because of it.

comment:6 Changed 13 years ago by akempgen

  • Component changed from Chat Core (IRC) to Colloquy (GUI)
  • priority changed from high to normal
  • Version changed from 2.0 (2D9) to Built Source

although not a duplicate, #294 would probably help to fix this

comment:7 Changed 13 years ago by timothy

  • Resolution set to duplicate
  • Status changed from new to closed

Yes #294 would fix this, marking as a dupe.

Note: See TracTickets for help on using tickets.